Device offline options? IDE?

With well over 100 devices at least once a month I have a device that goes offline.

When a device goes offline and none of the easy (power cycle, z-wave repair, etc) fixes brings it back online, I’ve been doing an exclude/include.

Are there any other options? The classic ST app has a ‘replace’ option but it never works for me.

Is there something I can do in the IDE? I don’t ind having to exclude / include but it is reseting up everything the device was used for that is a pain.

First of all, if your z-wave mesh it up to snuff, you should not have devices drop off line. Home many of those 100 devices are repeaters and how many are endpoints? Do you have enough repeaters closer in to your hub? When your device goes offline, if you bring it in closer to the hub, does it come back online then? Is your hub in a position where it is being blocked in some way? Is it close to your router? I would try and investigate why things are dropping off rather than come up with a better way to fix it.

I have
26 GE Switches / dimmers of which 5 are the Z-wave Plus
8 contacts- mostly IRIS. 2 smartthings v2, 1 v1
15 motions - IRIS mostly iris, some GE, some bosch
1 wired GE outlet
13 smartplugs mostly IRIS, Some GE
3 outdoor smartplugs GE
5 smartthings arrivals
8 iris buttons
3 smartthings buttons
2 Aeon remotes
7 hue bulbs
1 harmony
3 temp sensors
2 thermostats
2 arlo systems
3 garage door openers - iris

Hub is in the center of the house - 50 feet from router.

The last device to go off line was a garage door opener. Before that it was a GE switch.

Have you run zwave repair recently? If so, does it run without any errors or warning?

I run zwave repair at least 3 times in a row. And run it until there are no errors.

Are the devices that drop out, both zwave and zigbee? Or just zwave? Or just zigbee?

Have you tried rebooting your hub?

When you say offline, what do you mean? Do you mean that it shows “Unavailable” in the mobile app? or “offline” in the web IDE?

Does the device work even if marked offline? If you do nothing and wait does the device come back after a few hours?

If you view the “Events List” in the web IDE are there any errors listed that come from one or more devices consistently? Trying to determine if there are 1 or more devices that are messing with the overall mesh because they are malfunctioning?

Typically when they go offline they are zwave. Rebooting does nothing. Repair give an error for the device. They do not work in app or webcore. The only solution I’ve found when it happens is to exclude and re include.

At the moment its a GE Dimmer

Is the zwave error something like “cannot update mesh” or “device cannot respond”?

If it is anything other than “device cannot respond,” running zwave repair can help.

Did you ever run the zwave repair 3 times in a row?

Do the devices that report zwave repair errors change when zwave repair is run multiple times?

Last time I ran zwave repair I had to run it 5 times in a row to get a clean zwave repair.

Then I get a “failed to update route”

Yes, I run zwave repair until those errors no longer show up, yes those 2 errors messages usually show up together for the same device.

Last time I ran zwave repair I had to run it 5 times to get a clean zwave repair.

Also, the list events windows does not auto update, so I start zwave repair, then bring this window up, then wait 9 minutes and then hit browser refresh. If there are errors, “Rinse and Repeat”

I tried a repair 5 times… same thing every time.

Try doing a zwave replace from the app and replace with the same device, that worked for me last time.

I’ve never been able to get replace to work. It just spins and spins.

The device has to be in a bad state for it to work. You can’t just replace any device.

it is in a bad state right? or am I not following?


Are you only getting zwave repair errors for one device?

What kind of device is the one that is getting errors?

Can you flip the circuit breaker that one device?

Turn off for 10 seconds, turn on again.

Reboot SmartThings hub.

Then try zwave repair again and see if finishes without error.

At this time yes, before that it was a garage opener, before that it was a different GE switch.

GE in wall dimmer

Tried that

I even waited 24+ hours

Tried several times.

If history repeats itself… I can drop the hub in exclude mode and just exclude and include it and I will be good to go but that is what I’m trying to avoid.

So the good news is by running zwave repair more than once, you were able to narrow down mis-configured devices down to the one!

Now to just fix this last device.

So after the last zwave repair, you flipped the breaker? Or flipped the breaker in the past?

Remember wired devices are also repeaters. So this one device has a bad map to talk with the hub and since it can act as a repeater for other devices it can both have problems itself talking with the hub and can cause other devices to not be able to talk with the hub.

Just to confirm, with each zwave repair it looks like this, there is 2 errors messages for the ONE device and you see a start and finish zwave repair.

In other words you are waiting for zwave repair to finish each time.

So your logs look like this now
Z-Wave network repair started…

Failed to update mesh for device X
Failed to update route for device X
Z-Wave network repair finished…


Run first time get an error. Run second time no errors.