[Depricated] Lock Code Manager

I am having the same/similar issue. Any help would be appreciated. I have all slots enabled (30). When I slide the enabled? setting to on (enabled), that setting disappears after I press Done. I am able to set up codes, but not enable them. This happens on both my iPhone and iPad. I am using the latest version 4.1.5. I have a Smartthings 1.0 hub and a Kwikset zwave lock. I have been using this app for quite a while without this problem happening. I have tried to stay current with the updates to the smartapp and the device type. I haven’t been setting up or charging codes much recently, but noticed the problem. Does anyone have any ideas to help solve my issue? Thanks.

You should not set user total to 30 unless you’re actually using 30 user codes.

I recommend you delete this app and use the beta app instead, as it will help you to delete codes that you don’t specifically set in-app.

Thanks, I will try that…Will the codes I set up using 4.1.5 app stay programmed on the lock (I.E. Will the new app recognize the codes already set up there?) I am physically 2500 miles away from the lock I’m managing and travelling there is not an option for several months. I would still would like to manage the codes from my current location though. Thanks so much for your quick reply. Would be happy to provide feedback on your new app if I can get it working.

The new app will delete the existing codes on the lock. You’ll have to re-enter the codes in the new app in order for them to continue to work.

You don’t need access to the physical lock in order to perform the process. I just took a screen shot of my user list and then transcribed it to the new app.


I put the lock manager into the app today and gave it a try…Everything seemed to be going well just have a few general questions.

I am using a Schlage connect lock

Since I started using the app I had previously programmed a access code using the programming on the lock itself. Will this app overwrite that and wipe that out? or will that still be on the lock? It did not show on the lock in the lock manager, but still worked.

I had a interesting thing happen as I was leaving the house today, I closed the door and went to press the Schlage logo to lock the door and nothing happened. Normally this is how I lock the door, Did I mess up a setting in the lock app? I very much prefer to lock the door then having to use my phone to do that.

Any help or guidance would be great. Thank you

You probably need to be using the correct DTH for your lock.

garyd9’s DTH would probably work best. You may have to do some research.

I don’t have that lock, so I can’t attest personally. I don’t know why the design decision on the locks firmware would allow the lock key to be reprogrammed via ZWave. That seems… bad.

This app does not delete codes automatically, however if you program for instance slot4 for a code and then enter a user on slot4 on the app, the app will overwrite the manually entered code.

The new beta app has an option to overwrite all codes not entered on the app’s settings. I think this is the most user friendly setting for most people.

The option to press Schlage on the keypad to lock after you close the door is called “Lock and Leave.”

You (or someone in the home?) may have accidentally disabled it. I don’t think it can be turned off from the mobile phone.

In any case, to re-enable lock and leave if it continues to not work:

  1. Open the door
  2. Extend the deadbolt
  3. Press the Schlage button on the outside keypad
  4. Enter your 6-digit programming code (the lock will blink a small LED at the bottom of the keypad to indicate programming mode)
  5. Press 7 on the keypad

You’ll get one blink and one beep if the feature has been enabled
You’ll get two blinks and two beeps if the feature has been enabled

1 Like

I’m fairly new to ST and have only used it in it’s most basic form. I’ve just added a Schlage Connect and was looking for a better way to manage lock codes and ended up here. I have a couple questions I hope someone can help answer.

  1. Will this work with the Schlage Connect (it looks like so based on some of the posts)?
  2. My main goal is to be able to add and remove codes for people and the days/times they can enter, get notifications when some are entered. Both of these are listed in the features, I just want to make sure these are easy to manage/enable.
  3. Are the original post instructions easy to follow for a ST beginner, are there any predictable surprises I can avoid with a little insight?

Just trying to make sure this is the right direction for me to go before heading down another smart home rabbit hole :slight_smile:


Love the smart things hub and devices.
New user, and trying to update lock manager to the latest beta version to get the schedule function to allow scheduling of individual codes for a specific time frame. Bought a house that was a rental, that had this function using the nexia app, and converted to smart things. I installed the lock manager, but need to schedule codes for times.
I’m confused on how to update the prod code to the beta version.
I see the link zwave lock groovy updated 2 days ago. Where do I put this code?
Also, when I did the original config, I never had the reporting function available as a type, and only had z wave lock with codes.

Can someone put a step by step instruction to update?



Did you ever get Lock code manager working on your Kwikset 916? I have the same issue

Just noticed the following error showing up in the log file. Not sure what it means, i have not noticed any issues otherwise

a98a5636-ab04-4cb6-b054-0986dfc21d4c 8:01:46 PM: error java.lang.NullPointerException: Cannot set property ‘codes’ on null object @ line 251
a98a5636-ab04-4cb6-b054-0986dfc21d4c 8:01:45 PM: debug checking children for errors

This is a [Lock Manager] error.

If possible, try to keep discussion about that app inside of that apps thread.

It’s possible you just need to go to the parent app’s home screen and then click ‘done.’

I don’t have the 916 but I don’t think it would behave differently than the other locks.

Use the DTH and smart apps and you should be good to go. I don’t have a lot of free time right now to write a good tutorial on how to install these, but there are some around the community. Also, SmartThings support will help you get things installed if you contact them.

I am advising people starting to use the beta application instead of this one. It is more user friendly for people who are trying to find their way. This app should only be used for support of people who are still using the old app.

Has anyone else found that after installing this app (maybe the device handler) that I can’t lock the door with just the schlage button anymore? It seems I have to type in one of the codes or wait for the auto lock. Also, anyone else know if there’s a feature to change the autolock countdown?


If you are using garyd9’s DTH, “Lock and Leave” is on the phone UI. You can enable or disable it from there. I think this is disabled by default when the DTH is installed.

1 Like

I have a Schlage TouchScreen lock that I used with Wink prior to coming back to smart things. I have the device handler setup and the smart app and it works but there was a code already programmed in on the lock and the smartapp doesn’t register this. When I use the code to unlock the door, the smartapp history shows user 4 came in. How do I get the lock and smartapp to be in sync so it knows what codes are setup/available?


Each time I use the app, it is as if it is starting from scratch (its asking me to select locks). I would assume it would save my changes so I would be able to see all the users I just set up on subsequent app uses/logins.

Is this normal? or is this a bug? or did I do something wrong?

I have an iPhone SE, ST Hub2, Schlage Connect

Thanks you!

This isn’t normal. Unfortunately I don’t have any advice for you other than to contact customer support

The app doesn’t use any logic to do “smart things” from users already programmed into the lock. Logically this doesn’t work out. You’ll have to program in those users into the app in order for the app to perform actions on them.

Use the new app. I am no longer offering support for this one.

Thank you I was able to get everything working properly.