SmartThings Community

[Depricated] Lock Code Manager


(Fidel) #1506

Thanks Erick. I will try the Lock Manager Beta and do some beta test on Schlage Connect.


(Scott Horrar) #1507

Erik,
I installed three Yale nexTouch cylindrical levers with z-wave on my office along with a Samsung SmartThings hub. I downloaded and installed the SmartThings app and added your extension as well. I have 10 employees and plan to expand and I love how it lets me know when the lock was accessed, but it says it was accessed by “user 90” no matter who’s code is entered. Is there a way to determine which user accessed the lock?
Thanks,
Scott


(jkp) #1508

First thing Erik might tell you is to move over to the newer version of the app. :smile:


(Erik Thayer) #1509

That’s interesting. Could you send me the logs in the IDE on when someone uses the lock?

Here’s what you’d do…

Open the IDE and go to ‘Live logging’ and then let that run. Go to the lock and while it’s locked, enter a valid code and see that it unlocks… then lock it again and use another code, and see that that also unlocks the door.

Then go over to the IDE and click on the specific lock to filter it out for the rest of the chatter.

Copy that output and send it to me. It might give me some insight into what’s going on.

And yes, as jkp said, use the new app. If this is a problem with the old app there won’t be an update from me on it.


#1510

Hi. I have recently installed a SmartThings Hub to use with my new Schlage Connect (BE468) electronic lock for a vacation rental property. I need to be able to add and delete codes remotely. I have installed this app and followed all directions, but my first tenant was not able to get in with their personal code that I added remotely, so I had to give them another code which I added manually when the lock was installed. I am not sure why it isn’t working. On the app I can see where they are using the alternative code I gave them. Maybe I did something incorrectly, but I have looked over everything and don’t see how. My smartphone is a Droid Turbo, if that matters.


#1511

Welcome to SmartThings. It sounds like you have installed things correctly as you are getting user reports when they open the lock so I’m not exactly sure of your issue. What I would recommend is uninstalling the Lock Code Manager SmartApp and migrating to the new one as this product is no longer supported by the author. You should be able to use the same DTH (device handler) you have installed, but in case there is a change I’d recommend just installing everything from scratch. If you still run into issues feel free to ask in the thread I’ve added below and we’ll do what we can to help.


#1512

Thank you. When I click on “Device Handlers” I’m getting the message that I don’t have any device handlers yet, but I know I included one before when I added the User Lock Manager. Am I looking in the wrong place? I’m new to all of this!


(Realy Living Dream) #1513

If you followed Erik’s instructions, you should have installed the Z-wave reporting lock device type. Did you go into the IDE and make sure your lock is using this device type ?


#1514

The device type I have is Z-wave lock with codes.


(Realy Living Dream) #1515

Therein lies your problem. If you follow the installation instructions, it says that you need to use the included Z-wave lock reporting device type for apps to work.


#1516

I looked for that one, but did not see it listed.


(Realy Living Dream) #1517

It is in Erik’s lock manager git hub along with the apps.


#1518

Ok, again, new to all of this. Should I go here:

and paste this under Create New Device Handler?

Thank you for the help!


(Realy Living Dream) #1519

Yes, or follow the instructions in the thread posted above

to integrate the repository to yours. Then click " update from repo" and the lock manager repo from dropdown list. Don’t forget to check the publish box next to the update button


#1520

Ok thank you! Will let you know if the lock works next time we’re able to check it.


#1521

Ok, lastly, when I click on the top tab “my device handlers” it is showing the Z-Wave Lock Reporting. However, when I go to “my devices” and click on my lock, the type still shows Z-Wave Lock with Codes. So do I still have more to do?


(jkp) #1522

@KatieZ Now go to My Devices and find your door lock and click on the name. At the bottom of the screen, click on Edit. In the Type pull down list, find the device handler that you added and select it. Note, it will be near the bottom of the list, not alphabetically listed. Then click Update at the bottom of the screen.


#1523

Done! Let’s hope that takes care of it! Thanks a bunch!!


(Jay Libman) #1524

Installed the latest version today for a Schlage BE469. On the IOS app, i am unable to save the users and codes. Whenever i press done and exit the screen, they disappear. please advise,
thank you
Jay


(jkp) #1525

Jay - install the newer version :smile: