SmartThings Community

[Depricated] Lock Code Manager


(Jason P) #1473

I can’t get past these steps.

In the ‘Type’ drop-down scroll to the bottom and select ‘Z-Wave Lock Reporting’ or ‘Z-Wave Schlage Touchscreen Lock’

I dont have Z-Wave Lock reporting as an option under type. I’ve gone though the steps up until this point x 2, and still I can’t get “Z-Wave lock reporting” under my types?


(Erik Thayer) #1474

You must have had added that Device Type handler to your SmartThings library through the IDE.

Click “My Device Handlers”

Click “Create New Device Handler”

Click “From code”

If using a non-schlage touchscreen lock lock use this code:
https://raw.githubusercontent.com/ethayer/lock-manager/master/devicetypes/ethayer/zwave-lock-reporting.src/zwave-lock-reporting.groovy

if using a schlage touchscreen lock use this code:
https://raw.githubusercontent.com/garyd9/SmartThingsPublic/master/devicetypes/garyd9/zwave-schlage-touchscreen-lock.src/zwave-schlage-touchscreen-lock.groovy

Click ‘Save’

Click ‘Publish for me’

Then go back to editing your device and select the device type handler that you made in the above steps. Custom device types will always be last in the list of device types. Scroll to the bottom and select. Then save your changes.


#1475

I have the Schlage Connect Deadbolt Touchscreen and was excited to see this app. I’ve set it up as per the instructions. It now appears in my ST app under My Apps but unfortunately the settings can’t be viewed or changed on the ST app on my iPhone. When I tap on the app, it always brings to me to the ‘Select Locks’ option. I have gone through and set up the locks and clicked all the Done links to save.

However, whenever I go back into the app, it again asks me to Select Locks and start all over. It doesn’t seem to save my settings on the device.

If I use the website and look at my Device, it shows User Lock Manager listed and if I mouseover it, the settings that I entered do appear. Unfortunately, they are not in the app on my iPhone.

I’ve set up two codes and they are actually working now when I test them on the lock but still, I can’t change them (or even see them) in the ST app on my phone. I’ve even logged out and back in several times.

Help!


#1476

Look for it under Automations > SmartApps


#1477

Thanks @eibyer. Now I feel like an idiot. I was expecting it to show the settings when I selected it in the Marketplace.

Perhaps it shouldn’t appear there if the app is already installed…? It turns out I installed the app multiple times without realizing it.

Seems to be working great now. Thanks for creating this @ethayer


(Dana ) #1478

Since you’re just starting, the version of this app recommended by the developer is below:

It says “beta” but it is completely stable/daily driver and resolves various issues in this version…


#1479

It is useful if you want to maintain two or more locks, you can give it different names so you can distinguish which one is for which lock.


(Brian) #1480

I have downloaded the App and Device Manager but need help with the usage. Tell me if I can do this and if possible how:

Note: Used for a vacation rental

I want to assign different codes with different date ranges for the guests that book with me. It seems that when I assign a date range, it applies to all users (I want to to apply to only one user).


#1481

I have installed this app in smartthings. I installed the device handler for my Schlage lock. The app is very erratic. I set max users to 5 and then entered 5 users. Only 2 worked for the first few hours and then 2 others worked. The user in slot number 2 wont work. I tried deleting all of the codes and entering 1 at a time. I cant seem to delete any codes either. In other words the 4 of 5 originally set codes that worked still work even though i deleted them from the app.
Is there some sort of manual on this to show what each option is for?


#1482

Being that I had such a difficult time getting this one to work correctly (through much fault of my own), are there any special steps I need to be aware of when transitioning to your BETA version? Like deleting the “old” version of the app from my ST hub, resetting the lock, etc…etc…? I don’t want to clog up any threads with my over all “stupid-ness” again. :slight_smile:


(Erik Thayer) #1483

Good question. The new app is a Child/Parent app, so you’ll have two apps to install on your IDE.

Parent: 'Lock Manager’
Child: ‘Lock User’

You have to click “Publish” on the Lock Manger app, but it’s recommended that you only click ‘Save’ not ‘Publish’ on the child app. It’s not a big deal if you DO publish it, as it will just show up as an app on your marketplace that you’ll need to just ignore.

It is highly recommended that you delete the existing app as you transition to the new app. There shouldn’t be any need to delete any individual user codes. I just took a screenshot of my users list when I moved mine over to the new one, and then I used that screenshot to re-program in the old codes using the new app.

Both apps use the same device type handlers, so no change there other than maybe updating them if you haven’t done that in a long time.


(Jason P) #1484

Still not showing up. When I’m adding the device handler from code, what is the first line/character I highlight for the copy and pasting of the code? Maybe thats where it is going wrong.

[URL=http://s4.photobucket.com/user/chaostactics/media/z%20wave%20error.jpg.html][/URL]


(mike ricchino) #1485

That list is not alphabetical despite it looking like it… all your custom devices are at the end of the list.


(Jason P) #1486

@Micro, thanks for the feedback. The right pane of the screenshot is scrolled all the way to the bottom of the Type list


(Jason P) #1487

If it makes a difference its a Kwikset 914 with Z wave, i’ve attached screenshots of the app install process and device handler install process. It still doesn’t show up when I try to edit the lock.

[URL=http://s4.photobucket.com/user/chaostactics/media/z%20wave%20app%20install.jpg.html][/URL]

[URL=http://s4.photobucket.com/user/chaostactics/media/z%20wave%20added%20device%20handler.jpg.html][/URL]


(mike ricchino) #1488

I dont know how i missed that… my bad.

ok im digging through my install… and everything does seem to match yours.

My device handler is 682 lines long… but im pretty sure if you were missing lines it would error on publishing.

I know there are 2 IDE servers… and some people have to use the secondary one but you would know if that were the case because your devices wouldn’t be listed.


(Ryan) #1489

I followed the steps to install a couple days ago and thought I had done it successfully, but am having trouble with the app. I go to the Samsung SS app, then Marketplace, Smart Apps, My Apps, User Lock Manager. I select my lock and then proceed to set # of users and assign a pin code to each user. When finished I choose “done” and get the message “User Lock Manager is now installed an automating.” But then when I return to the app none of my changes have saved and my new pin codes don’t work on the lock. Maybe I am missing a step somewhere?


(Ryan) #1490

I think I found my mistake, never mind!


(Jason P) #1491

Thoughts from anyone else? I’d rather support an Indy app instead of having to buy a micasa to control my stupid door lock. I’m thinking in should have bought the micasa instead of the Samsung hub :confused:


(Jonathan Rivera) #1492

Hey Jason,
You’re logging into the wrong IDE servers. Take a look at this screenshot where you’re looking at your device handlers

Notice the graph-na02-useaste1.api… in the URL?

Now look at where you’re publishing your Device Handler

What I like to do is when I log into the IDE, I go to My Locations -> Click on My Home and if i’m on the wrong IDE server it will redirect me to the right server that I should be on.

100% this is your issue. I’ve done this in the past.