SmartThings Community

[Depricated] Lock Code Manager


#1407

@ethayer would have a better idea of how to answer that but he did state this about the new SmartApp:

I think the above list will get the app out of “BETA” as the features will be robust enough to replace the old app. At that time, I will remove the old code as to keep new users out of that path.

I’d just recommend using the new lock manager SmartApp.


#1408

Using lock manager and so far it is working great. My only question is that every 2 minutes 10 user Lock manager items appear in the ST activity feed. Is this normal and what does it represent? I am assuming it has to do with the 10 users I have setup. Is ST polling the locks every two minutes? Will this kill the batteries in the Locks?

Thanks


#1409

This happens if you have null users. If you set only 2 codes be sure to set users to only 2. Any higher and it will poll. Fixed in the new lock manager app above


#1410

I think i have one null user, will delete and see if this fixes my issue. Thanks for the feedback!


#1411

I actually uninstalled and reinstalled. It is still polling and i have 5 users setup. However when i retrieve lock status it shows users 1-30 USers 6-10 have the old codes and users 11-30 are Null codes. What version of the app is the latest. I think i have 4.1.5

In the Activity feed it is now showing only 10 lines of USER LOCK MANAGER.

So not sure what to look for now. If you need screen shots of anything please let me know.

Thanks again


#1412

The new code is a complete rewrite by ethayer. It is located here.


(Dana ) #1413

@jhamstead/@ethayer :

Just tried to add the smartapps and device handlers for the Beta in the IDE, but getting a persistent error on installing the DH. The Smartapps loaded fine.

This is the handler I see in the IDE:

devicetypes/ethayer/zwave-lock.src/zwave-lock-reporting.groovy

Error:

Updated 0 devices and created 0 new devices, 0 published (1 skipped due to errors)

Any suggestions? I did remove Ethayer’s original lock manager.


#1414

I usually only see that error when integrating with GitHub. Are you pulling this straight from GitHub or manually copying the code?


(Dana ) #1415

Integration - added his repo using 'ethayer" and “lock-manager” and updated from repo to get the Smartapps just fine, it’s just the device handler that is erroring out when I update from repo.

Are you saying that you have to create the beta lock manager DH from copy/paste code, rather than via GitHub integration/update from repo? I was able to get ethayer’s original lock manager DH via integration, so it did work w/that version.

Really appreciate your feedback and help!


#1416

You can use the same DH you installed for the old lock code manager or copy the code manually. I believe ethayer did not create the DH in his GitHub account correctly so you get that error. Someone else noted it in the forum. I guess it has not been fixed.


(Dana ) #1417

OK, great, thanks! I still have his other repo in my IDE, so I’ll just do an update from that repo for the DH.

Very helpful, thank you very much. Can’t wait for my lock to arrive. (But I guess that’s obvious.) :smiley:


#1418

Thanks for the push in the right direction. Everything is working great!

Appreciate the quick response!

Happy New Year


#1419

Anyone having issues where the lock code manager reports the door being locked like 5 times in your notifications? I’m not sure if I set it up improperly and somehow made it trigger multiple times. I figured it was unlikely because the unlock notification only shows once.


#1420

I’m getting the same thing. Just posted about this actually. I’m only getting it for “Locked” messages and not the “Unlocks”. About 5 “Locked” messages will pop up in my notifications.

Anyone else getting this? I’m on an Android device. @Torgysk not sure if you’re using Android as well and if that matters.


#1421

I am actually using iPhone and iPad applications. My issue was fixed with the BETA version of the software that was referenced in a few post ago.

I have been doing home automation for over 10 now, but I just got my ST hub at xmas, so a steep learning curve.

I do not have notifications turned on at the moment, so i cannot comment. I may turn mine on, and see what happens and report back, but that won’t be tonight as my son has hockey.

Good luck

JT


(Dana ) #1422

Yup - recommendation I got was to use this:


#1423

For what i am using it for, it is sufficient. I have not had any issues, and it did solve a polling problem for me that was killing my batteries.


(Dana ) #1424

Did you mean this version, or the beta version when you say “it is sufficient.” ? Sounds like you’re saying that the beta version solved your polling problem, correct?


#1425

Yes, i am using the beta version. It has solved the polling problem for me.

JT


(Loren Swanson) #1426

I am using an older smartthings V1 hub with a new Schlage Camelot Lock and I am having trouble getting it to properly connect and report current status. I have tried resetting the Schlage to default and removing it from smartthings and then re-adding it to the hub. It can lock and unlock the lock but status is always reported as unknown. Is this an issue because it is a v1 hub or what am I missing.

Thanks for any advise.