SmartThings Community

[Depricated] Lock Code Manager


(Jeff Hobbs) #1249

Any luck on this through trial and error? I am having the same issue and trying to determine if its an issue with my device type or something else. thanks


(Lauren) #1250

Today is the first time I’ve tested our lock with someone feeding our pets. It disarmed the system but when they left it did not arm the system. Am I missing something In the app to ensure that our system is armed when the door is locked? We have the kiwiset 916 and it’s been locking and unlocking wonderfully for us as we come and go with our presence but I can’t figure out how to have the system arm when the door is locked on the touchpad.

Thanks!strong text


(Jeff Hobbs) #1251

Found it out, you can just use the default setting. My lock is on a detached garage, so sending the user codes over that distance was the issue. Dropped a repeater in half way and it worked well. Then just removed the repeated and all is good. My ZWAVE garage door monitor should be here Monday, which will act like a repeater and should boost the entire area.


(Erik Thayer) #1252

Yo, just an update.

##Lock Code Manager Update##
Bad news: There won’t be one. I am no longer going to be providing code updates or support for this app. The code is old and clunky… And I don’t really have the time to provide support AND code. It would be awesome if you, as the community would support new users on this app has you have been. At least until…

Good news: I’m working on re-factoring it to work even better. I have a new app that’s stable for setting codes, but it’s lacking most of the features this app has. Once I get scheduling feature in the new app, I’ll release a beta. It will have fewer features than this app off the bat, but should catch up quickly, and will surpass ‘Lock Code Manager.’

##General Update:##

I initially stopped working on Lock Code Manager because ST had hinted at their own integrated system to be released ‘within weeks.’ That was almost two years ago and there’s still no integrated solution.

Since I stopped providing updates, my life has sucked. Lots of family loss and stress, so I just haven’t had time to work on a side project. I still don’t know if I have enough time, but I’m working through it.

I’m going to shoot for a beta next weekend. No promises. Most people will PROBABLY want to stay on this app for awhile, but for those who just want to set codes and schedule users, the new app will work.


#1253

Thanx for the updated info, Erik … and hang in there!

I’ll be trying your new app …


(Erik Thayer) #1254

The new app thread: [BETA!!!]


(Phil Panfili) #1255

I am finding that none of my lock codes are burning or erasing, even if I get rid of them in the app.

I have a cleaning lady who I want to supply a code for only once, and then have it burn… But it will not go away now… Even if I delete the code all together it is still working…

Am I missing something here?

Is anyone having same issues?

Is this app even supported by anyone anymore?


(Sean1279) #1256

I have a Schlage Century lock and I can’t seem to get this app to work with it. I didn’t see any mention of the Century lock, so I thought I’d check. The app appears to find the lock, but now suddenly the user codes from the schlage manual don’t work. Strange.


(Sean1279) #1257

…annnndd nevermind, your new app works perfectly.


(Andrea Bianco) #1258

Glad you are back Erik!


(Andrew) #1259

Big thanks to the devs for putting this together. Quick question while trying to understand the functionality of this custom app:

I am not see anywhere to enter the programming code for a Schlage Camelot BE469 within the App. Is it correct that the app is able to bypass knowing what the lock’s programming code is and can program user codes without it?

Just wanted to confirm this to make sure I am understanding correctly.

Thanks,
AG


#1260

Eric bad news man. The latest version of the Android App 2.2 kills your smartapp. As of a bit ago can no longer modify user code settings now get “you are not authorized to perform the requested operation” and then a Remove button underneath. Deinstalled and reinstalled the app same thing. Old version running on my tablet still works fine…


#1261

This is a bug with the Android 2.2.2 release. Not the SmartApp. This bug affects appears to affect all SmartApps with children, even the SmartThings smart lighting SmartApp.


#1262

Yep I know…was quite obvious when previous versions of the App (not smartapp) work just fine. Just wondering what else they managed to break…in fact dreading it… anybody have the previous version of the app .apk handy?


(Cameron) #1263

Same as last 3 above me. App is broken on my Android Nexus 6P :confused:


#1264

Hey, I just updated the SmartThings app on android to the latest version and now I am not “authorized” . here is the log. any thoughts? thanks
f06e3273-d7f9-4197-9910-0cea7fd644fe 11:36:00 PM: error groovy.lang.MissingMethodException: No signature of method: static java.lang.Math.round() is applicable for argument types: (java.lang.String) values: [2222222222222222222222222222222222222222222222222222222222222222222222222222222222222222222222222222]
Possible solutions: round(float), round(double), find(), rint(double), find(groovy.lang.Closure), random() @ line 310


#1265

If you can roll back your app to 2.2.1 and then stop auto updates you will gain functionality again until they can fix this…I happened to have a tablet with the older .apk and just copied it over and reinstalled.


#1266

Yup. confirmed. I just did that a few minutes ago. Here is the link - http://apkfind.com/root/apk/2016/10/6/com.smartthings.android_207901.apk?id=com.smartthings.android&f=SmartThings%20Mobile_2.2.1_apk-dl.com.apk


(Nutellapr) #1268

What measures should a user take to ensure this app is secure? I don’t see any Oauth instructions. Thanks for the help.


(Erik Thayer) #1269

This app does not use any third party services.