[DEPRECATED] webCoRE Installation Process Feedback

That part I understand, the question was in reference to the two new apps @ady624 added to ‘speed up the system’.

You have nothing to pause so that is fine, do not pause anything.

The install was rather easy. However, I thought finding the installation instructions was more difficult than the installation itself. A quick google search brings you to this feedback page. It would have helped to have a link to the instructions in this post.

FYI - I’m new to GitHub and custom SmartApps for ST.

So when I click on Smart App to add WebCore it just spins and doesn’t take me Next. When I go back and check my repository, doesn’t look like OAuth is applied. When I try to apply it I get denied. Any ideas?


I just discovered this app today but I am having an issue trying to install webCoRE.

I have installed the 4 packages from github(webCoRE first, then the next 3). They show up in the SmartApps page as published.

When trying to OAUTH, I get this error:
Access Denied
We’re sorry, but you are not authorized to perform the requested operation.

I have logged out and back into SmartThings. I have deleted the 4 files and reinstalled them. I have tried Chrome and Firefox but still no luck.

Anybody have any other ideas on what to try?


Check if it’s a shard issue.

That’s the same problem I have.

I logged in from another computer and OAUTH now worked fine.

Not sure what changed but all seems good now.


Ok, well this morning , Auth worked. Now I seem to have 8 instances of WebCore in my smart apps. How do I delete the others?

Ok, looks like I had to set my password on each instance. Once that was done I was able to access setting and remove each instance one by one.

This is getting really frustrating. I’m following every step in https://wiki.webcore.co/ however I am coming to a dead end when it comes to installing the SmartApp in the mobile app.

In the https://wiki.webcore.co/GitHub_Install step I make sure to install one at a time. Followed by the OAuth of wecCoRE. I follow the steps exactly as they are written.

Any ideas on what could possibly going wrong? I am new to the CoRE scene, as I just got the CoRE setup in the mobile app, just looking to expand to the webCoRE.

What is the “dead end”? We can’t help unless you tell us what the symptom is, and “dead end” doesn’t quite explain it well :smiley: I am going to go on a limb here and assume you can’t find the app in the My Apps section of the ST app, so I’ll ask, did you make sure to tick the “Publish” checkbox while importing the apps? If not, you can open each one of the four and click on the Publish > For Me up top.

Yes sorry. Like I had stated. I had followed everything to the T per the wiki instructions. I ended up reaching out to a smartthings Facebook group. Apparently I was logging into the wrong shard?

Regardless, I got it all setup after realizing I was in the wrong IDE. Thank you anyways. I can’t believe it was the simple.

1 Like

Glad you figured it out :slight_smile:

I am final getting around to WebCore and I installed and published all four code segments, assigned devices, chose a password and able to login to the web interface.

I am confused because in my Automation/SmartApps I have 17 versions of webCore. Only the last one in the list contains the setup information. All the others act like brand new setups. Any idea why this happened? And is there a way to get rid of all the decoys?

Here is what it looks like from the IDE

Not sure what caused it but I ended up deleting everything and did a fresh install and it didn’t put a bunch of extra WebCore.

I cannot access to https://dashboard.webcore.co/ it just keeps loading (grey background with animated square at lower right). My pistons are working fine though so now I cannot create/edit anything. Been trying on my mobile 4G network, home ISP and office ISP, all browsers authorized. Any idea?

Can you please hard reload the browser? Any error in the console?

Hi Ady624, no error at all, it just keep waiting on the grey background with the animated square at lower right

By the way, if I use a new browser, it does ask for authorization code. Once I entered, it is back to the screen I described… If I refresh it, it asks for authorization again…