[Deprecated] Thinking Cleaner 2.x (Roomba Control)

Not related to the smart app at all but has anyone had issues where the think cleaner module is stuck in battery saver mode, the 8 second red light? Over the weekend I added a wireless access point and after that 2 of the 3 roombas are stuck in this battery saver mode and I cannot get them reconnect to the network. I have removed them from the thinking cleaner server, reset both the roomba and the tc module and removed the battery, all to no avail.

I haven’t seen anything like that, but here is the info from Thinking Cleaner:

Roomba has not been charged for some time, Thinking Cleaner will blink red and is not working
When the battery charge of your Roomba gets below 10% and Roomba is not working and charging, Thinking Cleaner will enter a battery safe mode. In this mode Thinking Cleaner uses mucht less power and the battery will last longer. To get the Thinking Cleaner working again connect Roomba to the charger or place it on the homebase.

You may need to reach out to them for support.

Also, check to make sure no pins are snapped off in the connector… yes that happened to me…

Thanks guys. I just had another thought. I am reluctant to swap the last good tc module as I don’t want to fry that one, it would a last resort in troubleshooting. But I was just thinking, why not try swapping the battery from the good with one of the bad ones to see if that helps. There were no battery saver issues prior top me adding the access point, so i am thinking that the 2 tc modules are just stuck in battery saver. I have reached out to support but have not heard back yet.

What version of Roomba do you have? I have 2 560’s and they always had trouble on any code greater than the 1.4 release. I might try the new code again to see if anything has changed.

I have the 550 Pet Series. I was finally able to get one of the two working. haven’t had time this week to troubleshoot the second one.
I just started everything over from scratch in SmartThings, and started over on the Thinking Cleaner app too.
I did a complete reset of the Roomba by pressing and holding the SPOT and DOCK buttons for 30 seconds

Those having issues with the previous versions have been successful by resetting the thinking cleaner module and restarting with the new device type and smart app

AB0E5:0050

AB0E5:50

@pmjoen thank you so much for this awesome integration. I’ve been trying to get this to work for about three hours and can’t seem to get it to play nice.

This is what i’ve done:

  1. Installed Device Handler & Smart App

  2. Modified the device handler to have my IP & Port:
    preferences {
    section(“Roomba Network Information”) {
    input(“ip”, “10.11.0.229”, title: “IP Address”, description: “Your Thinking Cleaner Address”, required: true, displayDuringSetup: true)
    input(“port”, “80”, title: “Port Number”, description: “Your Thinking Cleaner Port Number (Default:80)”, defaultValue: “80”, required: true, displayDuringSetup: true)

  3. Went to “Add New Device” added it as Roomba, i entered the network ID (by converting the IP to AB0E5:0050).

  4. Open smart things, look for new devices, found “Roomba”

  5. Open SmartApp, link it to Roomba

Then it gets stuck on “checking”

I’ve also tried adding the device handler without the IP information in the ST app but it continually tells me to “enter all information” even tho everything is checked.

Am i not doing something correctly? I Would like to also setup a concrete how-to guide to help others like me.

Can you please turn on debug in device and send the live logs. Usually when it just shows checking it means it is not connecting.

Thank you for the help. When i try to make any changes in “settings” on the Roomba device, it errors in red telling me to fill out all the fields. Screen shot below

These are the logs from “Roomba” (name of the device)
ef67ea9d-826a-41af-992a-b7a6ced8bb62 6:44:25 PM: debug The Refresh Status Command was sent
ef67ea9d-826a-41af-992a-b7a6ced8bb62 6:44:25 PM: info Thinking Cleaner Version 2.2 Copyright © 2016 pmjoen
ef67ea9d-826a-41af-992a-b7a6ced8bb62 6:44:25 PM: debug Updated with settings: [:]
ef67ea9d-826a-41af-992a-b7a6ced8bb62 6:42:41 PM: debug The Refresh Status Command was sent
ef67ea9d-826a-41af-992a-b7a6ced8bb62 6:42:41 PM: info Thinking Cleaner Version 2.2 Copyright © 2016 pmjoen
ef67ea9d-826a-41af-992a-b7a6ced8bb62 6:42:41 PM: debug Installed with settings: [:]

These are the logs from ThinkingCleaner:
f0a29b15-8a39-47cf-8455-f1326c71310f 6:44:51 PM: trace groovy.lang.MissingPropertyException: No such property: displayName for class: java.lang.String
f0a29b15-8a39-47cf-8455-f1326c71310f 6:44:51 PM: trace Error checking status.
f0a29b15-8a39-47cf-8455-f1326c71310f 6:44:46 PM: info Thinking Cleaner Version 2.0 Copyright © 2016 pmjoen
f0a29b15-8a39-47cf-8455-f1326c71310f 6:44:46 PM: trace Updated with settings: [sendPush:true, sendRoombaError:true, sendRoombaBin:true, sendRoombaOn:false, switch1:[ef67ea9d-826a-41af-992a-b7a6ced8bb62], autoSHM:[true], sendRoombaOff:false]
f0a29b15-8a39-47cf-8455-f1326c71310f 6:44:46 PM: info Thinking Cleaner Version 2.0 Copyright © 2016 pmjoen
f0a29b15-8a39-47cf-8455-f1326c71310f 6:44:46 PM: trace Installed with settings: [sendPush:true, sendRoombaError:true, sendRoombaBin:true, sendRoombaOn:false, switch1:[ef67ea9d-826a-41af-992a-b7a6ced8bb62], autoSHM:[true], sendRoombaOff:false]
f0a29b15-8a39-47cf-8455-f1326c71310f 6:44:44 PM: trace groovy.lang.MissingPropertyException: No such property: displayName for class: java.lang.String
f0a29b15-8a39-47cf-8455-f1326c71310f 6:44:44 PM: trace Error checking status.
f0a29b15-8a39-47cf-8455-f1326c71310f 6:44:40 PM: trace groovy.lang.MissingPropertyException: No such property: displayName for class: java.lang.String
f0a29b15-8a39-47cf-8455-f1326c71310f 6:44:40 PM: trace Error checking status.

Thank you again

I see a refresh command being sent but you are not receiving a response which means the Device is either not connecting via ip or there is an issue with the DT and SmartApp install. Is there a reason you converted the ip or added it to the code instead of in the settings of the device? I would say we troubleshoot one step at a time. Delete both the device/device type and start from scratch.

Create a new device in the IDE and assign the Thinking Cleaner 2.x device type. Open the device in smart things app and add the values in the settings instead of hard coding in the DT. Once that is configured send the live logs when you try to refresh so we can see the nertwork commands.

Step by step how to would be nice, if you create one let me know and I can attach to the initial post.

I have confirmed with Thinking Cleaner that the delayed clean is no longer working so the addition in ST integration is stopped until they can fix. Also they published a new firmware update that looks to be causing battery value issues with my Roomba, not sure if anyone else is seeing the battery showing --% and a status of off in the thinking cleaner app.

I deleted the device / smartapp / device handler.
Re-added the smartapp (from code), and Device Handler (From Code)
Added a new Device from the IDE (screen shot below)

Then I opened ST on my phone, installed the Smart App, linked it to the device “Roomba”
When i attempted to modify the settings for the device to add the IP, it keeps erroring (the same error i screen shotted above) that i didn’t fill in everything.

So right now i have the stock device handler and Smart App.

Regarding this: "Thinking Cleaner 2.x device type. "
In the IDE it just shows up as Thinking Cleaner, not 2.0

I wouldn’t even worry about the smartapp until the device is working. Im not sure why it is telling you that you are missing a value, please go into each setting value and change it then save (even if it is incorrect) then go back in and set the value correctly and save.

Going in and deleting everything line by line, then reentering it seems to have worked.
Now it’s showing that it’s docked, will play and post back. thank you!

Awesome, sounds like a cache issue with ST. Fingers are crossed, let me know.

Seems to be working, still playing around with it. Getting the Roomba to start cleaning is hit/miss right now. I have a routine that triggers when everyone leaves, and is limited to once a day. I then have my “im back” routine shut off the Roomba, so when i get back it goes back to the dock.

The other automation i did was create an Alexa Group “Maid” so i can say “Alexa Turn On The Maid” and the Roomba fires up. Pretty cool stuff!

The issue seems to be thinking cleaner tho, even through the webapp when i hit clean it doesn’t go. I’m talking with their support via E-mail.

@pmjoen Having a bunch of issues getting this wired up. I’ve deleted everything from ST and started over. This time I’ve also integrated with your git. I had this working perfect with the old smartapp/device handler so I can taste it.

Thinking Cleaner is active in the cloud. The native app works great. I’ve triple checked the IP address of my roomba and its correct.

I create a new device in the IDE and select the “Thinking Cleaner” device. Then I go to the ST app, plug in the IP address, and hook up the smart app for polling etc. But it never connects. I get the below screen.

Unfortunately I have no logs to share, because nothing is coming through.

Any thoughts? Is there something wrong with the Thinking Cleaner itself? Something with the firmware?

Thanks.

Greg,
In the thing settings be sure to turn on both debug settings and if you select refresh you should get logs. even without being a bee to connect we should be able to see what it is trying to do. Please try and lets go from there. Also please be sure to only have my thinking cleaner device type and smart app as multiple versions will cause issues.
Also I have a new GitHub that ill be using moving forward but there is nothing new so I haven’t published in the community. Instead of SmatthingsPublic it is SmartthingsMjoen.

Thanks @pmjoen

Here are the my logs.

bdc5d20d-dde1-45b5-8956-b0119144d5d2 2:26:29 PM: debug The Refresh Status Command was sent
bdc5d20d-dde1-45b5-8956-b0119144d5d2 2:26:29 PM: debug Executing 'refresh’
bdc5d20d-dde1-45b5-8956-b0119144d5d2 2:26:29 PM: debug Device Network ID Set
bdc5d20d-dde1-45b5-8956-b0119144d5d2 2:26:29 PM: debug The Refresh Status Command was sent
bdc5d20d-dde1-45b5-8956-b0119144d5d2 2:26:29 PM: debug Network is not connected
bdc5d20d-dde1-45b5-8956-b0119144d5d2 2:26:29 PM: debug Executing 'poll’
bdc5d20d-dde1-45b5-8956-b0119144d5d2 2:26:29 PM: info Thinking Cleaner Version 2.2 Copyright © 2016 pmjoen

“Network is not connected” ?