Will just add that battery percentage is also not updating, and setting the max length using the down button on the blind does not work. This is really strange. It almost seems I got a faulty unit. Will try to set it up without SmartThings and if that does not work either, this is the reason.

If you’re not getting battery percentage on the blind (or the remote) then try re-pairing as well - and make sure that the device you’re looking to pair is very close (i.e. next to) the ST hub.

I had similar problems, the IDE didn’t even show battery as an option on ‘Current States’ but a delete and re-pair worked fine, and the battery figures came across, together with the IDE now recognising it.

yes, tried re-pairing several times, also setting up the signal repeater in ST. I just finished setting everything back to default (using Ikea repeater and no ST). I am still having a problem…It will not set the maximum length by pressing the down button. Everything else works from the remote and the blind. So I think it is safe to say I must have got a unit with a minor fault. I will try exchanging it for a new, but it will take time.

Hello. Sorry for the basic question, but how do you pair these blinds? I’ve gone through every Fyrtur thread I can find. What device do I pick in SmartThings to pair? I’ve tried all the ikea devices as well as scanning in both new and old apps. I’m holding the blinds right up to the hub. What am I missing?

I figured it out right after I posted this. I messed up by manually adding the device after I added the device handler. I should have just added the DH then tried to pair. I got it working. Thank you Wayne for writing this DH for us.

Try re_pairing and operating in the same room as the hub. If this works then you’ve probably got a bad relay in the mesh somewhere.

Hi everyone,

I’ve been working on some adjustments to @a4refillpad 's (great work btw!) DH that I was wondering if people wanna try it out. Specifically, I was having some issues with the ability to set the ‘maximum drop’. The pairing of the button/zigbee extender didn’t work reliably for me despite repeated attempts. On my windows, using the above device handlers, I only want the blinds to go to 22 % closed and no further.

So in this DH that I modified, I have set a per device preference for Close Override. The integer value that you put in the preference will set it as the new 0 (Closed). So in my window, I set it to 22, and now when the shade lowers to 22, it considers the shade closed and will not lower the shade any more. It will also set the proportions correct too, so for example setting it to 61 is the new 50%, 80 is the new 75%, etc.

I am still working on a few bugs, like some of the refreshes doesn’t seem to work, but some feedback and bug reports would be helpful.

[edit] - GitHub link removed because I am stupid, I didn’t know that the problem was I was trying to get ‘maximum drop’ to work by double tapping the REMOTE, not the BLINDS themselves.

I may be mis-interpreting the issues you’ve been having, but with the @a4refillpad’s DH, the “absolute” close is whatever you program on the blind itself via the button - instructions i’ve found online below:

Hold the lower button until the blinds reach to the bottom of the window, release it, and then click the button twice. The blinds will do a little dance to signal the new maximum length. Now, when you lower the blinds to 100 percent they’ll only drop to the bottom of the window

yep, i’m not aware anyone else has this problem. I have three sets of blinds and all of them have been perfect at holding the max length using Ikea’s instructions. The changes @PhantomSpice are interesting though.

OK, so perhaps this is because I am an idiot. The problem I was having was related to setting the maximum drop.


Turns out what I was reading by doing internet searching was push the up or down button twice to set the maximum drop. I interpreted that to mean on the remote, not on the blind themselves. So I spent a good part of yesterday afternoon trying to get the remote to pair with both blinds, then hitting down down or up up on the remote and it would never lock in the maximum drop.

I did this for a good 2 hours, before getting utterly frustrated, and deciding to recode the DH instead (since that seemed to be faster to resolve). The whole time, I didn’t realize it was NOT up up/down down on the remote button, it was up up/down down on the BLINDS THEMSELVES… Ugh…

So anyway, I don’t need my revised DH now, I got the max drop set on the blinds itself, and everything is working now. Still great work on that DH @a4refillpad.

1 Like

Yes, it was my mistake. I interpreted this to mean click the button twice on the REMOTE, not the BLINDS themselves. That was my error. I had been trying to get this to work by pairing the remote, double clicking on the remote which never locks maximum drop.

I’m an idiot. Half a day wasted trying to figure that out.

We all have those kinds of days :slight_smile: Glad you sorted it!

Alexa integration seems to be working now, no updates to the app or firmware therefore must have been a backend upgrade.

Mine has lost 6 and 10% after 7 weeks. Runs automatically at sunrise/sunset + when high temp if open.
So not many runs, but the batteries is quick to recharge

so i got the up/down button handler and your little smart app but the blinds do nothing. checking the button device in smartthings its registering every press… i’ve configured the up and down button in the smart app… just does nothing…

Also has no one gotten this to work with google assistant without the tradfir hub?


Working great for me, this is brilliant, i haven’t tested held yet, but it does the basics for me, thanks a lot!

Confirming not working on V1 hub, per the other thread, but it does on V3.

Is the only way to have the Blind working with both ST and the Button to link them through webcore?

Just wanted to add, i finally got the clicker working with the shades, i didnt realize in smartthings you have to select a direction (up or down) AND you have to also select pushing the button down or releasing it… at least for me thats how it was, so i’ve set both up and down to work on ‘release’ seems to work.
I dont love the 25% for each click thing i’d rather have it go 100% since we cant have the feature of holding the button down to release when its at the height you want 4 increments dont matter to me much.

If using my smartapp, just tick “invert controls” it will than go all way up instead 25% steps

Ahhh i thought that meant it would invert my buttons…

Lool, it looks like the text isn’t as clear as it could be, I’ll change it next version.