[DEPECRATED] Neurio-SmartThings integration

@coolcatiger, this seems to be a bad callback URL… Did you generate a new set of API keys and specified the correct callback URL:


I know that the whole process is kind of complicated. As soon as the Android issue is solved, I’m planning to submit the code to SmartThings so that they certify it and integrate it into their SmartThings labs for easier setup.

You are really the first beta testers!

Thnx for your patience.

Sent you a PM. The big error glaring to me is this:

2:45:25 PM: error setAuthTokens> Auth error, neurio servers cannot be reached at https://api.neur.io/v1/oauth2/token?


@chevyman142000, this could be a temporary outage on the Neur.io side… Let’s try it later, and it still comes back, we need to contact Neurio support about it.

@coolcatiger and others,

I made some changes so that the creation of Neurio Appliances is done in 2 steps.

First, we create the Neurio device type during the 1st execution of the MyNeurioServiceMgr smartapp.

Then, in the second run (you’d need to execute MyNeurioServiceMgr another time), the appliances are created. You may select 2-3 appliances per appliance selection page (not more as there is an execution time limit in ST). FYI, There are now 2 pages where you can select appliances.

Could you grab the latest NeurioServiceMgr code at:

Don’t forget to save and publish.

You’d need to follow all the steps in the readme file at



Thanks, there was progress. but now I am getting this error.

I am on iOS and don’t have appliance setup yet. Is that the problem?

Hello @coolcatiger , just to be sure, did you update all the Neurio code: Neurio and Neurio appliance device types and also the MyNeurioServiceMgr smartapp?

Don’t forget to save and publish…

Please PM the logs of any errors related to the Neurio code above.

Thnx for your patience.

P.S. Also, don’t forget than under iOS, any time you update any device type code, you’d need to uninstall the SmartThings app and reinstall (as there are no way to clear the cache).

I was getting the same error. I ended up deleting ALL of the neurio device types and apps and re-adding them. It is no working!

@coolcatiger, @chevyman142000, I found a potential issue with the code that was checking if any child devices or appliances needed to be deleted in the MyNeurioServiceMgr smartapp.

I made some changes, and now, the smartapp seems to be more reliable now.

Please try it again whenever you have a chance.

Just update the smartapp code, save and publish.

Uninstall the smartapp under MyApps beforehand, and restart from scratch,


For what its worth, I was able to setup everything on my iPad and it is working fine. This causes the Smartthings app to crash on Android if the tiles are displayed. I moved all the Neur.io tiles into a group, so now on Android it is Ok as long as I do not open that group.

Hello @bradsileo, this is an open support ticket, # 101078, about it since May 9th…

Still waiting from ST Android Engineering team about it, sorry.

That’s why I posted this thread on the Neur.io community:



Hi Yves,

I tried to activate the MyNeurioServiceMgr smartapp, and when it tries to connect to My Neurio I get a “redirected_url in the request does not match that of the specified application” error. Is there a step I’m missing? I’m on the android ST app with a V2 hub.


@sracine, please grab the latest code of MyNeurioServiceMgr smartapp (v0.8.8) at my github as Neurio seems to have hard coded the redirection URL path somewhere…

I’ve tried it on my end and it works now.

Please support the developer :grinning:

Works great! Thanks for the quick response, this is certainly worth my support.

Is there any way to edit which tiles show up for the Neurio device? I don’t generate any power. Also, what is ENERGY supposed to represent? Is that the total calculated since the Neurio was installed?

Merci infiniment!


  • Is there any way to edit which tiles show up for the Neurio device?

No, not at the moment. Maybe later when dynamic tiles will be available.

  • Also, what is ENERGY supposed to represent? Is that the total calculated since the Neurio was installed?

Yes, Energy is the total calculated for a period.

Merci infiniment! Pas de quoi.’

Et, merci pour votre contribution.

Is there an Android version, and if not, what’s holding it back, errors in the Android app interface?

Is there a quick description about how this works anywhere? I’ll keep searching, and clearly there is the Neur.io site I’m combing, but I’m curious what the appliances are, do they come from Neur.io, or are they energy monitors/switches in ST? Sorry for any obvious questions.

Hello @bridaus,

Apart from the official web site, you can look into the community forum site here:


ST has been aware of this issue since the Android V1.7 upgrade mess…The ticket has been open since May 9th. I’ve done many representations to ST about this UI issue, but the Android Engineering team seems to be too busy to fix it.

The issue is sproadic: not all the Neur.io appliance objects are affected. For instance, at my home, only the Dryer is crashing the Android UI.

BTW, the UI issue does not affect the main Neur.io power & energy meter exposed to ST, just some appliances detected by the device.

Hello @Tyler, I have some issues with Android 1.7.2.

As previously discussed, I created a Neurio Service Manager for instantiating some Neurio Device and Neurio Appliance objects into ST.

See my device type code at github:

The service manager is under

The Service Manager works only on iOS for the moment (as there is an ongoing support ticket with the login page not loading properly on Android), but that’s not the issue I want to expose here.

The objects that I instantiated with the Neurio Service Manager can be properly loaded into the Things shortcut on the iOS dashboard, but not on Android.

It looks like an object created under iOS cannot be loaded in the Android UI? I would have thought that an object is UI & OS independent, but it doesn’t look like it in my use case.

Please advise.

They come from Neur.io which can infer the appliances by looking at their power consumption signature. The appliance detection is far from perfect (especially in a ‘busy’ house), but it works for big items such as dryers, air conditioners, water heaters, etc.


@yvesracine, can you confirm that I need to have the Neur.io device in order to use their service or not?

If not, how do I get an account?

thanks. I’m evaluating Power Consumption applications at the moment, there are many to choose from in this space now.

yes, you need the neur.io device in order to use their service.

You may also want to look into Curb.


But if it requires something other than my HEM, I won’t consider it. I want generic supported devices. No one off companies. I want to own my data.

Nuer.io is exactly that, a one-off company where you don’t own the data. I have one and use @yvesracine’s integration method for Android devices. I can’t say I use the integration really for anything other than getting the usage data into my own DB for tracking purposes.