CT101 Z-Wave Thermostat no longer working for routines (Nov 2022)


Logs have been sent. Account Data Access was set before I sent the email requesting assistance from support.


Hi Andres,

I am also facing the same issues. Followed the steps described above - however, I cannot figure out how to send a DM on this board.

It also looks like the routines are not working correctly. For example, I have a routine as follows: at 7am, adjust the heating temperature to 75 degrees. These routines seem to work once (it is random) in a while but mostly they do not work. Is anyone else seeing this?

Just click on the person’s name and click the message button to DM that person.

that’s the thing - I don’t see any message button… sorry :frowning:


Can you take a look at my response from November 29? It doesn’t seem like anyone with coding experience has commented to my question about the Edge driver source files and if they are formatted correctly.


Sorry about that, we requested the information to investigate further because the fingerprint is not the problem, they look very similar but they differ in the productId field, one is 0x000C and the other 0x000B.
The first is the one that identifies your device, you shared the model above:

The extra comma shouldn’t be an issue either, if it was, it would appear in the logcat after the device discovery.

I had been having issues with one of mine last week and after much frustrating troubleshooting I discovered that it was set to Auto and the built in programs were overriding the Smartthings Routines. Setting it to manual solved my routines issues.
I have 6 and had never had any issues. I don’t know if something changed in SmartThings or in the thermostats. Intuitively I would have though Auto would be the way to go. Maybe I never looked before.

@SmartFire what was set to Auto? What built in programs are you referring to? What did you set to Manual?

I have a Heat Mode which has an Auto but there is no Manual. And I have a Fan mode which has an Auto but also no Manual.

CT101 hubV2
Cannot change temperature from app. Hit minus from 73 degrees and app shows 72.2 , not 72 , after waiting errors out. Why is this offset here? Was never here before.
Using Alexa routines everything works fine.

1 Like

Same here exactly

Same, here. Two CT101s. Edge driver. Routines which include a Thermostat scene work randomly. Running scenes directly (not part of a routine) that change temp don’t work either. Adjusting temps in the ST App works. ST App rarely updates except when adjusting temps in the app. I’ve reset both thermostats with no effect.

FYI, all thermostats seemed to have worked as scheduled last night and this morning. Great to have a warm den for my morning coffee!

I think we are on our own here. I had posted this quite a while ago. Followed the suggestions in the community, to include the recommendation to log a support ticket to track the problem with Smartthings support. Unfortunately they have been less than helpful. They keep asking for the same information which was provided when I created the ticket. They even closed the first ticket I created with no update.

I don’t know what people are going to do if they have CT101 thermostats and want to continue to use them with their Smartthings hub using automations.

1 Like

Wow could it be fixed? I am able to adjust my thermostat using the ST app this morning without an error. First time in about 2 months and the first time this heating season.

I probably shouldn’t jinx myself with this post but wanted to check with others to see if they were able to set the temperature in the ST app also?

I didn’t try the automations because mine have been deleted too many times during the debugging and I haven’t added them back.

Let’s cross our fingers that Smartthings fixed this and just didn’t tell us
Just like when they broke it.

I have been using the Rboy driver for the last couple of years because the stock dth ate batteries on two of these thermostats that I have. Hopefully the new Edge driver doesn’t do the same. After I started using the Rboy driver the batteries would last a year or more. The stock driver would burn through a set in 3 weeks! Same issue with the similar Gocontrol models.

The CT 101 is operating again. Merry Christmas everyone


I am still having the same issues. Which Edge driver are you using?


Mine is not using the Edge driver

Not working again.
Oh the joy of SmartThings
Think I’m done
Going to Apple products