CoRE - Get peer assistance here with setting up Pistons

Also tried this

Will post an example pic shortly

Does yours work. I have it set up just like this one and all zero’s and I am watching the wind change

Yes, I get the notification. I go to Weather Tile and hit refresh, then I get the pushed notification if it had changed from previous value.

Here is mine…looks the same to me

It does look the same, only difference is our device.

I am watching the wind speed change so I know it is kicking out info. CoRe just is not grabbing it. I guess I can try a weather tile which is pretty much what I have already. Can you let me know the device that you have loaded

I’m using the ST stock weather tile

I guess I will delete it and try again. I wish I could see some logging

You can try enabling debugging/trace on the piston and watch live logging.

So here is the deal and I did this by accident. I deleted and put it in again. Except I hit temperature instead of wind speed…and guess what…after refreshing it gave me the temp. I changed it back to wind…and nothing. So there is something going on

so where does it put the log

Log in to IDE and go to Live Logging tab.

yea found it. nothing is being picked up by the core. I can see where all the info is coming from the weather tile

The Weather Tile device shows up like this in live logging:

‎1‎:‎55‎:‎17‎ ‎PM: debug WUSTATION: event: [name:wind, value:5, unit:MPH]

it looks to be a CoRe issue. When I change it to Temp. No issue. I can see the variables being passed. However when I change it to wind…nothing

CoRE depends on the device handler to give correct info so if there’s something malformed in the dh’s data, CoRE might not pick it up.

can you send me your device handler or point me to the location of the one you are using. I could not find just the Weather Tile. I think that is pretty old. Now it is called smart weather tile. Here is what I am finding.

Humidity, Illuminance, temp and water it will provide. Any of the other variables with the little house by them…none of them work

It’s been a while since I messed with this but you probably will get the same result from AccuWeather from Marketplace > SmartApps > Climate Control > AccuWeather Connect

Edit: And there is this one if you have not seen it yet.

yea that is the one I am using and again all I can get is temp, hum, water and ILL…all the other stuff no go