Contact sensor lag?


#1

Hi all. Brand new ST user here, My goal, for now, is use the contact/multipurpose sensors to tell me when windows/doors are opened and closed.

I started with a Samsung multipurpose sensor. Got that paired, but it never proactively updates to tell me when the contact was open or closed - it continue to report the same state until I go do a different page. As in, if the contact is closed, the status will show as closed even if I open the contact. If I then go into device details it will show as open, and stay open (even if closed) until I return to the dash/devices page. If I close it and change the page it will report correctly.

This isn’t working as expected.

So I went to Lowes and picked up an Iris contact sensor to see how it would behave and it is behaving the exact same way.

I removed/repaired everything. Reset the hub, tried different ports on my router (yes, long shot…) I also set up an automation to alert me when the status changes, but that doesn’t work either.

Is this behavior by design or is something not right?


#2

That’s not normal behavior. Try the FAQ and see if it gives you any ideas. (Those are both zigbee sensors by the way) ( this is a clickable link)

Also go ahead and get in touch with support, they may be able to see something from their side.

https://support.smartthings.com/hc/en-us


#3

Thanks for that. I tried what I could, including pulling the batteries and power, and no luck. I’ve contacted support to see what they can figure out.


(Jimmy) #4

Sounds like zigbee mesh issues. Move your hub away from wifi routers, check for zigbee/Wi-Fi channel interference.


#5

I checked my channels. Zigbee is on 15. Wifi was on auto setting to 8. I changed it to 11 just to test.
ST hub is about 5-6 feet away. Sensors I’m playing with are line of sight at about 5-6 feet as well.

Behavior is the unchanged.

I turned off the 2.4ghz wireless on my router, didn’t change anything.

Any chance I’ve just gotten a defective hub? When I was doing the initial hub pairing it wouldn’t autodetect on the network; I had to manually add it by selecting the device type and entering the provided code, if that helps at all.

(and no word back from Support yet either)

Thanks


(Jimmy) #6

Wait, what device type has a code?


#7

Yea, in the ST box under the hub there’s a cardboard sleeve with the purple booklets inside. There’s a QSG (quick start guide) on the outside of the sleeve with a “Welcome code” and instructions to keep it. When I first connected the hub and tried to find with the phone it didn’t locate it while scanning. I had to select that I was adding a hub from all the device types (sensors, tv’s, etc.) and then enter the welcome code. It took that and added the device.

I did just get off the phone with support (email got me nowhere) and they’re escalating to the engineers. You can see the events from the sensor when you log into the hub via the website (I’m realizing how feature poor the app is) but they still don’t reach the app without a refresh. We did a few things like clearing the cache, trying the Classic app, turning off battery saver… nothing worked.

I’m going to try installing the app on an old phone I’ve got gathering dust in a box and see if that gets me anywhere.

So now I see what they come back with while I’m still in my return window.