SmartThings Community

Connection to Domoticz defined devices like Blinds and On/Off switches

somfy
x10
rgbw
project_shades

(Martin Verbeek) #684

Pfew, that is how it should be… what brand of switches are using that also report kwh? neo cool?

Verzonden vanaf Samsung-tablet.

-------- Oorspronkelijk bericht --------


(Dick) #685

Philio Technology Corporation PAN04-1 Double Relay Switch 2x1.5kW with Power Measurement+

I think that when the error is solved within the ‘Adding capability Graph’ section, then the ‘=Graph’ errors are also solved.

Yeah, I think that the changes are more or less good, except for the above error. Maybe when that is solved then the meters are listed as Sensors and then the page defined by ‘setupCompositeSensors’ will be presented as well and I can make composites (for the first time, :joy:)

Regards, Dick


(Martin Verbeek) #686

made the setup for the page a bit different, could you update to 7.18. Also get a new DTH for domoticsOnOff, it might solve the graph thing as well.


(Dick) #687

Hi Martin, it’s getting better! But the graph thing is still there.
I did a fresh install. After configuration the log shows a couple of warnings:

During this configuration it was not possible to create composite devices; though the page was there to enable, but nothing was listed. So I pressed Save and the above warnings showed up.

I did a second configuration by entering the app again, and now on the composite page two devices (power and gas) were available. I linked the power device to the power and the gas device to the gas. That works: Great!

I think just before entering the second time, or precisely at that moment the log shows again:


All errors with the same MAC address.

I still receive the graph-errors. In both Domoticz Server log and in the device=Graph log, with exactly the same error tekst as before.

I also get a new error, after doing the composite thing in the APP:

When the app is doing its thing, the app logs every 4 to 5 minutes the nexts 2 errors:

The APP shows me the gas metering:


It shows “no data”. Is that allright?
The 707 value is the current total value. Don’t know about 0.253. Probably the last usage between two samplings. That’s good! The gas metering in the device list in the app shows the last usage, not the usage of that day (707). For me something I would like to change, but that’s not important.

The same for the power metering (display and value’s).

And are the values updated now and then?
After 1 hour the values are still the same:

Great job!

Happy year ending and happy new year.

Regards, Dick


(Martin Verbeek) #688

Going somewhere now. Will follow-up on the errors. The Warnings are not important, only once when the devices are created.

Could you check the contents of the notifications created on the p1 devices? The app relies on notifications being sent when somthing changes. I copied the setup from power utility devices, but not sure if that is correct. If you can leave the logging running and check for eventDomoticz messages coming in with values related to the power reporting devices… if nothing happens let me know. I will try and guide you through on how to get the info i need :slight_smile: I sort of guessed what was needed. Might need your help on debugging that one.

could you paste the content of state.devices? particular interested in the ones with index 10000 and 10001. Do my locations, list apps, select domitcz server, goto State…

met vriendelijke groeten,

Martin


(Dick) #689


Sure I can do that, but I’ve to travel with my laptop now and then, so the logging is suspended then. Up to now, the values of both gas and power are not changed (same values as yeserday, not updated). Only the two already mentioned errors pop up every 4-5 minutes. And an additional error, with the same interval:

Do you mean this?


With some jobs that are scheduled:

Regards, Dick


(Dick) #690

Also with the same interval:
image

And in Domoticz the log shows the power 135 P1 notification, the gas 137 P1 is not logged:
2019-01-01 01:25:57.704 Status: Notification: SENSOR 135 KWH 739
2019-01-01 13:25:57.713 Status: Notification: SENSOR 135 KWH 304


(Martin Verbeek) #691

some message you get for free in domoticz, this debug is one of them. It looks like notifications for Power are coming through correct from DZ into ST. Also the state devices are correct. only thing missing i a message that power from sensor 135 is related to device 10000.

something like
image

for Gas i think we have a notification issue. Could you go into the device notification for Gas and see what types you have in the dropdown when adding a notification. I need usage greater than 0 for http.

Just clear out the current definition and add the one above manually, but before doing that hit CRTL-SHIFT-I (chrome) you will see debug window.

when you click add it will show a json.htm in the debug window with addnotification in it. click it and go to the headers, i need the contents of the request url under general. Same for power but i think those are okay…


(Martin Verbeek) #692

the 0.253 should be current usage.


(Dick) #693

It’s there already, same list as of with the power:

image

That’s is possible.

The json.htm’s:

For 137 (Gas) greater than 0
/json.htm?idx=137&param=addnotification&tmsg=SENSOR+137+Gas+$value&tpriority=0&trecovery=false&tsendalways=false&tsystems=http&ttype=14&tvalue=0&twhen=0&type=command

For 137 (Gas) greater than and equal to 0
/json.htm?idx=137&param=addnotification&tmsg=SENSOR+137+Gas+$value&tpriority=0&trecovery=false&tsendalways=false&tsystems=http&ttype=14&tvalue=0&twhen=1&type=command

For 135 (Power) same but ttype=5

Parameters:
image

Headers:
image

Hope this is what you requested.

More:
With 135 Power, one can choose between ‘Verbruik’, ‘Vandaag’ and ‘Last Update’. ‘Verbruik’ is registered.
With 137 Gas, one can choose between ‘Vandaag’ and ‘Last Update’. ‘Vandaag’ is registered. ‘Verbruik’ is not a option.

It is not possible to change the current row/notification?

Regards, Dick


(Martin Verbeek) #694

the reason for clearing the notifications is that i need the request created by domoticz (there is no good documentation for it), the existing request is created by the app ;-). If you clear the notification and add the request manually i will get the correct parms. Below is example of the command that was used after an Add of the notification


(Dick) #695

The info I sent you was made with newly created notifications :tada: :sweat_smile:

Regards, Dick


(Martin Verbeek) #696

there should not be a tmsg parm in the request, that is something i put in (or did you do that yourself also??)


(Dick) #697

:flushed: me? :joy: Don’t think so.
All involved switches and (belonging) power meters have similar tmsg.


(Martin Verbeek) #698

Could you do me favor and clear the notification on the gas p1, and when empty do the manual add again? The resulting json request should have an empty tmsg, this is the one I need. :sunglasses:

met vriendelijke groeten,

Martin


(Dick) #699

No problem.
Now I understand what happened. Before I added the notification, I clicked on the existing line. This way the optional field message was filled. When adding a new one, I used the settings as provided by the first one, did a change only on the ‘Greater than’ and pressed ‘Add’.
Sorry. Here’s the right one for the Gas.

/json.htm?idx=137&param=addnotification&tmsg=&tpriority=0&trecovery=false&tsendalways=false&tsystems=http&ttype=14&tvalue=0&twhen=1&type=command
image

+++

image

+++

image


(Martin Verbeek) #700

thx, checked and changed a parm in the app. Also found another issue with Gas reporting. added some additional callback handlers for specific call to get more info when an error occurs.

I think the errors are related to a second request for add of notifications.

Also did some changes in the DTH domoticzOnOff code to get rid off the =Graph errors.

many devices have been updated on repo to include some additional metadata for the non classic app.


(Dick) #701

Installed this version.
What about the composite device for the reports? Do I have to assign them (again)? There are already 2 reporting Devices, so….?

When I do select the Create composite page in the app, then ‘Add capabilities’ for one of both devices it shows ‘You can’t currently add this’:

Is that allright?

Each 4-6 minutes the following 2 errors are logged:

In ST, when I press on the (blue) value of the Gas reporting Device (presenting 0.253 W) the following error occurs (logged in the Gas reporting Device):

image

The same is true for the Power reporting Device (presenting 634.0 W).
The Power reporting Device reports the following data:

The gas reporting device report still ‘no data’

That’s it for now.

Regards, Dick


(Martin Verbeek) #702

errors are fixed (i hope), hard when you do not have the real device :slight_smile: .update from repo devices and smartapp


(Dick) #703

I’ve scene’s and groups. The scene’s appear to work fine, the groups not. For instance I’ve a group that turns all lights off or on in the living room. When I toggle this in ST the log of DS shows two errors and nothing is send to Domoticz.

Regards, Dick