Connecting ST open/close sensor to a Zigbee Dongle


(chen zarfati) #1

Hi All,

I would like to implement a simple Zigbee network where SmartThings open/close sensor will be a resource in it. I would like to do so with Telegenesis ETRX375 dongle, while doing that I’m experiencing a strange behavior - the sensor joins the network and leaves soon after without announcing. Can you point the problem?

The dongle is set to support HA profile.

Thanks!!
Chen


#2

Unexpected Leave and return for a zigbee device is almost always a mesh problem. Caused by one or more of the following:

  1. low battery. Solution: new battery.

  2. device almost out of range. Solution: add more mains powered devices to strengthen the mesh, then do a network heal. (Battery operated devices generally don’t repeat.)

  1. local interference. This could be at the transmitter end, the receiver end, or anywhere in between. WiFi is the most common culprit with zigbee. Solution: make sure the zigbee dongle is at least 6 feet, and preferably 10, from the WiFi router. Same for the sensor. If necessary, change the zigbee and/or WiFi channels.

  2. physical blocking. Different materials block signal. Foil backed insulation is a common “mystery” factor. Solution: same as out of range, add repeater devices.

Also, just to be sure: by “telegenesis 375 dongle” did you mean the 357 Telegesis USB stick? The Telegesis products are really popular for prototype design, but have some quirks. Their USB stick comes in two versions, a low power which is really low power, basically intended for bench design, and a “long range” which is more like a typical retail device. If you are using the Telegesis stick, which version do you have? If it’s the low power, that really limits range.


(John Rucker) #3

Chen, are you setting up the dongle as a coordinator with a new Zigbee network and having the sensor join it? Or are you still using the SmartThings hub as the ZigBee coordinator and both devices joining that network?

When you say the sensor joins the network and leaves how are you determining this? Do you have a sniffer? If you do have a sniffer it would help to see the packets.

Thanks.


(chen zarfati) #4

Hi, thank you very much for your quick answers!

@JDRoberts:

  • the sensor is new and the battery is the same, I’ll try that and update.
  • as I test this, the sensor is located less than 10cm away from the coordinator.
  • tried the setup in different location (work/home) without any change in results.
  • yes I meant the 357 Telegesis USB stick, I cant find the version details you mentioned, mine is ETRX375USB firmware R308. Again, the distance is minor so I would eliminate this cause.

@JohnR:

  • yes, setting up the dongle as coordinatior and I want the sensor to join its network. I don’t have the SmartThings hub.
  • I determine that parsing the at-commands prompts I get in the terminal. I do that together with Telegesis support, however we can’t point the reason yet :/.

Some of the prompts I get:
SED:000D6F0004058626,8D1E,-37,FF

RX:000D6F0004058626,8D1E,0000,00,00,0013,0C:&o

SED:000D6F0004058626,B640,-28,FF

RX:000D6F0004058626,B640,0000,00,00,0013,0C:@&o

SED:000D6F0004058626,56A9,-28,FF

RX:000D6F0004058626,56A9,0000,00,00,0013,0C:V&o

SED:000D6F0004058626,6409,-28,FF

RX:000D6F0004058626,6409,0000,00,00,0013,0C:<98><09>d&<86><05><04><00>o<0D><00><80>

SED:000D6F0004058626,D9D3,-30,FF

RX:000D6F0004058626,D9D3,0000,00,00,0013,0C:<99><3F><3F>&<86><05><04><00>o<0D><00><80>

SED:000D6F0004058626,4240,-27,FF

RX:000D6F0004058626,4240,0000,00,00,0013,0C:<3F>@B&<86><05><04><00>o<0D><00><80>

SED:000D6F0004058626,E91B,-45,FF

RX:000D6F0004058626,E91B,0000,00,00,0013,0C:<9B><1B><3F>&<86><05><04><00>o<0D><00><80>

SED:000D6F0004058626,9850,-35,FF

RX:000D6F0004058626,9850,0000,00,00,0013,0C:<3F>P<98>&<86><05><04><00>o<0D><00><80>


(John Rucker) #5

Ahh I thought so. I have done this same thing to a Hue Light bulb but with Digi’s ZigBee SMT USB dongle it is based on Silicon Labs Ember EM35xx chip. I had to run the USB dongle in API mode (Not AT command mode) and wrote a c# application to send and receive the commands. It wasn’t a trivial process but it worked great!!

so I don’t think I’m going to be able to help much here except it does look like your device at 0x8D1E is sending a device announce over and over. I’m guessing that is what this line is: RX:000D6F0004058626,56A9,0000,00,00,0013,0C. ZDO cluster 0x0013 is the device announce cluster. I wonder since it seems to be sending it over and over if it is expecting some type of bind command to come down from the hub. Generally the device announce is only sent once after a device joins a network or is powered back on.

Good luck, keep us posted on your success!!