Claim hub again?

After experiencing a couple hours of essentially nothing working, I found this site:

https://graph.api.smartthings.com/

I wanted to start over, so I deleted the hub from here. Now it says I don’t have a hub and I need to claim one from the app.

How do I do this? (Only) After logging out of the app it recognized the delete, but has not prompted me to add the hub and I can’t find an option to add/claim it.

(This is my first experience with ST. It seems really flaky. Was it worse tonight (2200-2359 CST)?)

Answering own question. This is something I had tried, but tonight I have found that killing the app, logging out, or simply repeating steps multiple times is necessary to accomplish things.

To claim the hub again, you can Add Thing > Connect Now => When it’s working, app will notice there is no hub and prompt you.

Of course even this seemingly failed (according to app), but I could see the hub again in graph.api…so I killed the app, which then gave me an error about not being able to load, so I retried 7-8 times until it worked.

1 Like

I am not support, but this may help:

Should be able to connect to it likes its new:

When I set up my hub (months ago) it got hung up somewhere and I had to contact ST to un-bork it.

Hopefully this will get you on the right path, let us know how it goes.

1 Like

Overlapped on messages.

Glad you got it working, The past week ST has been hit and miss. Its getting back to normal. You can see the troubles here:

http://status.smartthings.com/

1 Like

Thanks for the status link!

Everything just started working normally about an hour after I wrote. Now I’ve quickly got all my devices setup.

I’ve even ordered a few more devices just now…

I just found the developer site. I had previously set up a ST hub without problem. Right now it’s only managing a Schlage lock (but this will change shortly when I install a bunch of other things). When I went to the developer site and logged in it said I don’t have a hub but can “claim” it with the mobile app. I have an Apple iPhone 6s+ with the latest app, but there is nowhere on the app that I can find to “claim” a hub. Can someone enlighten me?

Victor

Duh, It seems that even though I was logged into my account and could view my smartthings, I wasn’t logged into the developer site. So instead of telling me that I wasn’t logged in, it just said that I had no hubs and could claim one in the mobile app (there’s no button called “claim” there). Bad design!

Right now I am trying to get to the bottom of a problem. I have presenced for both my iPhone and my wife’s and have associated them in the “I’m Back” routine to unlock the lock on the front door. This always works for my wife and never for me. My phone does show as present but the door never unlocks! I have a sneaking suspicion that it has to do with modes. Whenever I’ve come home from work my wife is home, so that the mode is Home. However, I can’t find any way that the Home mode affects the behavior of the lock. There seems to be no way of associating its behavior with that mode. Does anyone have an idea?

Hi,
I’m having the same trouble as you but I am logged in to both the iOS app as well as the developer site. however, in the Developer site, I get the same error as ypu ‘Please claim the hub in the app’.

Anyone care to explain? I am affraid of hard resetting and thus getting into another issue of havingntomrequest a new activation code.

Thanks

In case it helps, I have noticed if I log on to the IDE site and try to click on hub or devices I get no hub/no devices etc etc.

I have to click on locations, then log in a second time, and then it all works.

6 Likes

i been having this issue couldn’t,this didthe trick thanks alot!!!

that worked

Thanks very much had same issue solved my problem :slight_smile:

Try to take notice of the URL you get redirected to when you get logged out - it will probably be https://graph-na02-useast1.api.smartthings.com/ instead of https://graph.api.smartthings.com . Those are dependent on your shard. If you go directly to the URL you were redirected to next time you try to login to the IDE you won’t have to login twice to see your hub.

1 Like

That workaround works, but would it be possible for SmartThings to fix the login design rather than offer a workaround? I just fumbled around for two hours trying to figure out why I couldn’t publish a smart app and get it to show up on my phone app, only to find out the issue had been known for months.

There are development tickets to enable SSO for those pages which would address this issue by allowing all users to login to https://graph.api.smartthings.com and redirect them behind the scenes to the correct shard. The work just needs to be prioritized. I would suggest opening a support ticket in regards to this issue and mention that you ran into PROB-1166 (tracking number for this specific issue). I think there is a disproportionate number of support requests for this issue because people end up finding the answer on the forums and don’t bother opening a support ticket - I’m guessing that pretty much everyone who is on NA02 and has tried to publish a custom SA/DTH has run into it.

fyi @Aaron

1 Like

I had this exact same problem, and it started a spiral of nob mistakes that took me hours to resolve. If you get the message “Please claim the hub in the app”, there are a few simple steps to navigate through this bug in the SmartThings software:
1.) From the “Please claim the hub in the app” page; click “My Locations” (top left corner of page)
2.) You should see your location as the one item in the table (hopefully)
3.) Click the name of your location in the “Name” column
4.) You will then re-login using your normal credentials (for no apparent reason)
5.) After the login screen, you will see your location details (a full page of technical stuff you will eventually understand someday).
6.) Now, click on the “My Hubs” link on the top of the page again.
7.) Celebrate your success in seeing your hub listed.
8.) Feel the deep satisfaction in knowing that you were able to successfully overcame a software problem generated by one of the premier technology companies on Earth.
9.) Repeat these steps every time you get this error, it will happen often.

5 Likes

Thanks a lot works.

Thanks for the step-by-step, I finally got it to work.

I have tried everything suggested by @averagejoewastaken and others. To be honest I do not have an issue where my location requires me to log in. However I cannot seem to get the hub to appear on my account. In addition I logged off the hub on the app and reclaimed using the pin but still nothing.

I feel like I am going mad here. I am in the UK and tried the euwest URL as well as the standard, but nothing. Without this I cannot add my own handles is there something I am missing. Please help

© 2019 SmartThings, Inc. All Rights Reserved. Terms of Use | Privacy Policy

SmartThings; SmartApps®; Physical Graph; Hello, Home; and Hello, Smart Home are all trademarks of the SmartThings, Inc.