Child devices and Alexa

I don’t see anything that jumps out at me that would cause Alexa not to work. Kinda strange.

Thank you for thinking about it, I do think it’s a fundamental problem with the devices, as IFTTT can’t see them either…

Here are the links to the Device Handlers in case you’re interested:

Throwing my hat into the ring as well. My @Eric_Inovelli Fan + Light switch child devices are not showing up in Alexa, not sure whether it’s an integration or handler issue.

Here is the hander for the parent:
https://raw.githubusercontent.com/InovelliUSA/SmartThingsInovelli/master/devicetypes/inovelliusa/inovelli-fan-light-lzw36.src/inovelli-fan-light-lzw36.groovy

And child:
https://raw.githubusercontent.com/InovelliUSA/SmartThingsInovelli/master/devicetypes/inovelliusa/switch-level-child-device.src/switch-level-child-device.groovy

Hey @Kevin_Reene – let me look into this with Eric M. They’re showing up in my Alexa app, so I’m not sure what’s happening. Granted, I had them paired prior to the non-production version of the switch. I’ll try in the office today to see if it can work.

NOTE: Elena’s Light shows up halfway down the list – but the above screenshot shows both the, “Master” switch as well as the one Child device (and Notifications).

EDIT: Possibly it’s because I did it before May 7th per this thread?
Updates to Google integration (I know I’m using Alexa, but possibly it’s something similar. I’m not sure. I’ll continue to check it out today with Eric M.

2 Likes

Yeah looks like child devices are not showing in new integration:

Check in your alexa app whether the device is from “smartthings” or if it is “Smartthings Switch” or something after smartthings. Note, once deleted its gone for now, so don’t do it in my name!!!

Dang, I was so happy with my new switch. Thanks @Eric_Inovelli for supporting your product 24x7 I hope you find a solution for this, Alexa integrarion is critical.

Hey guys, not sure if this will work but I’m 99% sure it will… It’s a workaround for now:

I know this is for our fan/light switch, but it can be used for any multichannel device.

2 Likes

@Eric_Inovelli Perfect! I can report it does work, can you maybe put a * on the Fan Dimmer link for now? On a side note I had to go to the old app to add the Smart Lightning Smart App as the new app gave me nothing, once enabled it did show on the new app.

What do you mean? Sorry, I’m still waking up – was a late night last night!

Hmmm… that’s strange – but good to know! It’s been a while since I added Smart Lighting to ST, so maybe that’s what I did too – not sure :slight_smile:

Glad to hear it works!

We’re actually releasing a SmartApp today that will make this much easier for everyone. More to come!

2 Likes

If you are releasing a “Fix” today my first point is useless, WOW that is fast! I meant the landing page of the QR, that is what I used to set it up and loved it!

@Eric_Inovelli on a side note, is there a page for a wish list of new Inovelli products? I would love to see a 1 Gang Dual Switch, this configuration is very common offshore and has a painful selection.

Thanks!

Is there any difference when isComponent is true vs false?

Looks like the state is not being sent to alexa.

Working device:

Blockquote
Capability states: [ brightness: 100; TimeStamp: 2020-07-03T02:08:06Z; UncertaintyTime: 0; DeepQuery: True ]
Capability states: [ powerState: ON; TimeStamp: 2020-07-03T02:08:06Z; UncertaintyTime: 0; DeepQuery: True ]
Capability states: [ connectivity: OK; TimeStamp: 2020-07-03T02:08:06Z; UncertaintyTime: 0; DeepQuery: True ]

Failing devices:

Blockquote
Failed to retrieve state

Just did some testing, i deleted the child devices where isComponent is true on 1 device and false on another. The ones with children containing isComponent: true continue to fail state retrieval. isComponent:false child components retrieve state and work with alexa.

Update:
Pass isComponent:false to addChildDevice would probably do the same without the need for an additional smartapp and keep the child device associated with the parent. This creates the virtual child device which can be invoked from the parent. I verified the child device is visible in alexa (for me it was a motion sensor). I couldnt verify google assistant, but other the parent devices started working which is a very good sign.

1 Like

Yeah, it’s not a fix per se, but it’s an easier way to accomplish what I outlined above. It’s still a step back in the overall scheme of things.

@rym002 - I’m not a coder by any means but are you saying there’s a fix potentially that can be added to the handler?

If so, I’ll tag @erocm1231 as he’s the knowledgeable one here!

I can clarify the child device issue with the new SmartThings Alexa and Google integrations. Currently, only devices with a “main” component are being sent back to Alexa/Google.

Hence, a multi component device with “main” and for example two more components such as “switch 1” and "switch 2 " would only expose the “main” switch. If the “main” component was named “switch 0” it would also not be exposed correctly.

If the main device is spawning of unique child devices with “main” components, that will also work.

Does that help?

1 Like

Are you using the new Alexa integration? From what I saw when the child devices were created with isComponent true or false they did not show up in Alexa.

Our device handler has been calling addChild with isComponent: false but they still didn’t show up with the new integration.

How do I check which integration I am using? When the issue first appeared, I had deleted all my devices and disabled the skill to refresh all states. I can see the child devices I create from my DH which are motion sensors. Here is the code for my Device Handler.

How do we specify the main component?

I’m not sure how to tell, but I am creating mine the same way. I cannot find them in Alexa. The new integration is adding all of my devices from all the locations and hubs for my account. So I have a few hundred devices to search through. Most of them I used for testing and they are offline so it is a mess to search through, but I’m pretty sure they are not adding.

From all the reports about it and that they have explicitly stated that they don’t work with the Google Home integration I am thinking you are somehow using the old integration. Who knows . . .

image

1 Like

I cant say why it does or does not, only the behavior I saw. I just got a inovelli fan + light and observed the same issue in Alexa. I am new to this platform and still feeling my way around. Sorry I couldn’t be of help.