Child devices and Alexa

Hey there people, firstly, thank you all for the advice you’ve freely given (to me and others), so helpful and useful :slight_smile:

I have SmartThings and use Alexa to control lights and stuff, and specifically am using these switches:

With the Device Handlers in this thread:

The switches are really good; when you set up the DH, the first switch shows as a normal (parent) device, and the other three are child devices.

They all work fine in SmartThings, with both the current and Classic apps.

However, Alexa doesn’t see them, and if I do an import scan from SmartThings, Alexa doesn’t discover them.

Obviously I can set a Scene to turn each switch on, and off, which works ok for turning things on, but that’s really ugly to manage, having to say to Alexa:

  • Alexa, turn on (scene name)’

So to turn off a lamp, I’d have to say something like:

  • Alexa, turn on dining room lamp off.

Obviously I can do something a little less ugly like:

  • Alexa, turn on bedtime (or something).

But is there something better I can do? I can use IFTTT to use ‘Alexa, trigger xxx’, is there a better option with SmartApps, or Automations? Or can I make the child devices accessible to Alexa?

Thank you so so much!!

Are the child devices a virtual device? Also, are you using the new SmartThings Alexa skill, or the older one? I thought I read in the discussion below where virtual devices may not work, but I can’t validate because I’m still using the old skill.

Hey there John - thank you so much for getting in touch.

The Skill is the new one, and they’re not virtual devices as far as I know. They are actual buttons on the four way switch, and are not referred to as virtual in the app or IDE. They are ‘cloud’ rather than ‘local’ though.

Thank you for your input, any help is grateful received as I’m not sure what the best thing to do is.

@Dan_Rowland

In the SmartThings New App ==> “Settings” ==> “Connected services” ==> “Amazon Alexa” ==> “Switches” - Have you allowed access to the switches? Are the switches ticked? :white_check_mark:

Thank you so much for getting back to me, but with the latest Alexa Skill (apparently) you can’t select which devices you want to give Alexa access to. This is is how that page you refer to looks:

From what I’ve read, ALL devices are accessible by default, and if you don’t want any, you have to remove them.

@Dan_Rowland If you delete them in the Alexa app, they’ll come back. You have to disable them. Hopefully this gets addressed soon…

Yes, that’s right, bit I don’t want to exclude anything, I want to make the child switch devices appear as they do in SmartThings.

This is how they look in the SmartThings IDE:

You don’t need to delete them in ST, just Alexa. I always go to alexa.amazon.com to delete devices from Alexa, but you could try the Alexa app too. After you do that just kick off an Alexa discovery.

Yep I did exactly that, I deleted the device, and did a re-discovery, and it came back (as I wanted), but the child devices (that I also want) did not reappear.

My problem is that I want the child devices in SmartThings to be also available in Alexa, and I cannot find any way to make them appear.

Ok, bummer. When you click on those devices, does “In Use By” show Alexa?

Interestingly, I’ve checked all of my devices, and none of them say Alexa (although they do work with Alexa).

They just say IFTTT and the ST Automations they’re used by.

Oh man, that stinks. That’s one of my issues with the new app and Automations. You can’t go to a device and see what Automations that device is in use by, and now we can’t see Alexa in that list if you’re using the new skill.

@prjct92eh2, any suggestions?

Yeah it seems a bit poo, if anyone has any suggestions I would REALLY appreciate it :slight_smile:

Actually, I notice that these child devices are also not available to IFTTT, so it seems there is something fundamentally wrong / different with them…

I have two z-wave devices that seem to be passing their child devices to the new Alexa skill fine. (a zooz double plug and zooz multirelay). But now that i’m thinking about it, the virtual switches for my inovelli switch did not get passed to Alexa. Let me look at the DTH and see if I can spot why.

2 Likes

Ooh that would be amazing, thank you so much, I really appreciate your help!!

I don’t see anything that jumps out at me that would cause Alexa not to work. Kinda strange.

Thank you for thinking about it, I do think it’s a fundamental problem with the devices, as IFTTT can’t see them either…

Here are the links to the Device Handlers in case you’re interested:

Throwing my hat into the ring as well. My @Eric_Inovelli Fan + Light switch child devices are not showing up in Alexa, not sure whether it’s an integration or handler issue.

Here is the hander for the parent:
https://raw.githubusercontent.com/InovelliUSA/SmartThingsInovelli/master/devicetypes/inovelliusa/inovelli-fan-light-lzw36.src/inovelli-fan-light-lzw36.groovy

And child:
https://raw.githubusercontent.com/InovelliUSA/SmartThingsInovelli/master/devicetypes/inovelliusa/switch-level-child-device.src/switch-level-child-device.groovy

Hey @Kevin_Reene – let me look into this with Eric M. They’re showing up in my Alexa app, so I’m not sure what’s happening. Granted, I had them paired prior to the non-production version of the switch. I’ll try in the office today to see if it can work.

NOTE: Elena’s Light shows up halfway down the list – but the above screenshot shows both the, “Master” switch as well as the one Child device (and Notifications).

EDIT: Possibly it’s because I did it before May 7th per this thread?
Updates to Google integration (I know I’m using Alexa, but possibly it’s something similar. I’m not sure. I’ll continue to check it out today with Eric M.

2 Likes