Certain devices not responding to commands from same network


(Scott M) #1

Hello all, sorry ahead of time if this is in the wrong category.

I was able to get my SmartThings hub set up and added several devices, including 2 dimmer switches and paired it with my Honeywell Lyric Thermostat. The problem I am running into is that the Thermostat control works fine regardless of if I am on the same Wifi network as the SmartThings Hub(connected to router of course), however the dimmer switches will not. At first, I thought it was an issue with the hub, but when I attempted to control the dimmer switches while on LTE on my phone, the switches responded fine. If I am on WiFi or try to give them a command through my Amazon Echo(also on the same network), nothing happens on the dimmer switches.

I tried searching around, but couldn’t seem to find anything related to my exact issue, although I could be mis-wording it when searching. If anyone else has encountered this problem or has any suggestions, it would be appreciated! I have already tried Z-Wave repair, removing/replacing the dimmers in the setup, and tried turning the breaker off then back on, still no luck. I’m sure it has something to do with them being on the same network, or in the settings on my NetGear router, which I also tried some of the Port Forwarding info I found to no avail.

Thanks!


#2

Brand and model of the dimmer switches?

(BTW, the zwave switches use zwave to communicate directly with your Smartthings hub, not WiFi. Technically they’re not on your local network at all. The only thing that’s on your local network is the smartthings hub, which should be plugged into the router so it can use the Internet to talk to the smartthings cloud.)

So am I understanding you to say that if you take out your phone, you are connected to your local Wi-Fi, you open the mobile app, and then you try to use the smartthings mobile app to turn your switches on and off, nothing happens?

If so, that would be expected behavior if your phone (or your hub) did not have access to the Internet.

The reason is that the smartthings mobile app does not talk directly to your hub even if they are on the same local network. The mobile app always goes out to the cloud, talks to your cloud account and then the cloud account uses the Internet to talk to your hub.

If you have your local Wi-Fi operating but no Internet access, such as people sometimes do in RVs, your mobile app will not be able to talk to your hub. Technically it should be possible, it’s just not the way the SmartThings platform works.

So it doesn’t have anything to do with your Wi-Fi network being the same or not – – it has to do with whether your phone and your hub both have Internet access.

Smartthings is primarily a cloud-based architecture. Including its mobile app.

If I’ve misunderstood the situation, just let us know.


(Scott M) #3

Hi JD, my apologies for not providing that information. The Dimmer switches are GE/Jasco 45639(ZW3003).

Both the phone, hub, and Amazon Echo have internet connection, with all other internet-based functions working. While on WiFi, I am able to use the ST app to change information, settings, add things, etc. The issue I encounter is when I try to use the Amazon Echo or the phone(on wifi) to control the Dimmer Switches. The switches will not respond to commands from either one. However, if my phone is on LTE, the switches will respond to commands from the ST app.

For further thought, this morning I added a GE/Jasco In-Wall Outlet, and it has no issues with responding to commands from Alexa or the phone on WiFi.

Thanks!


#4

OK, that seriously makes no sense. :scream:

You’re saying that if your phone is on the Wi-Fi network, but it still has Internet access, you could open a browser and go to the news or whatever, but when you open the SmartThings mobile app and go to My home, and look at the things list, and find the GE wall switch, and tap the icon that that wall switch does not change state.

But that if your phone is on your cellular network and you do exactly the same steps, the wall switch does change state.

I can’t even imagine from an engineering standpoint how that could happen. I believe you, and SmartThings has surprised me before, but that one is just really weird.

Fortunately these are officially compatible devices, so support should be able to help. I would just get in touch with them at Support@smartthings.com and see what they can figure out.

If you want to look into the logs on your own, you can, but I’m not sure you’ll see anything that will help diagnose it


#5

By the way, the echo doesn’t actually control anything, it just passes a request over to the SmartThings hub and then the hub operates just as it normally does. So I don’t know whether there are echo issues or not, but the first step is to figure out why the switches are not responding to the official SmartThings mobile app. Because the most echo can do is trigger that exact same command pathway. Echo is just a different UI.


(Scott M) #6

Understood about the Echo, just pointed it out since it was on WiFi.

And if that alone makes no sense, I’ve got one better. This afternoon, the dimmers now work from the phone on WiFi as well as from the Echo. Not sure exactly how it got “fixed”, but hey, as long as it is working, right? :slight_smile:

I’ll take a look in the logs just to see if I see anything, thank you for the information. I’m just happy to have a system that works now, as I just made the migration from Iris, which after the “New Hub” update fiasco with them, never worked right again…