CentraLite Keypads

I’m having the exact same issue. Did u ever get it worked out?

If you have the devicetype already installed in IDE it should automatically associate it to the device when it finds it in pairing mode. What is the ‘Raw Description’ for the device as shown in IDE?

Unfortunately not. I going to try and test it with the xfinity version at some point this weekend and see if that makes a difference.

Hi Ben,

See this post for the raw description

I think it’s the same as the one in the device type?

So I’m not sure why you would be having issues when other people weren’t but I added the fingerprint of the IRIS keypad to my version of the device handler. Try this one out and see if it will pair automatically. I make no guarantees, my knowledge of ZigBee devicetypes is basic at best.

When I added mine I found it odd how I got mine to work.

Like you ST treated it as an unknown device/thing and put it in the list.

I selected it and added it in the App. Then went over to the IDE and changed the devicetype to Centralite Keypad.

At first the keypad didn’t seem to work properly. It wasn’t changing the SHM status.

If memory serves I believe I hit the Off button and waited then the Partial button and finally the On button.

Still it wasn’t working. I believe I put in a code like 1111 - On and still nothing.

I did notice the pad started behaving differently after doing this.

So like you I went to the App, selected the device and Clicked the Configure Button still nothing. Then I clicked the Refresh button.

This is the part I am not certain about but I tried either pushing the Off/Partial/On buttons then entering a code like 1111-On.

I may have even rebooted the ST Hub. I believe I went back to the App and clicked Configure again and for some reason it started showing me Temperature and Battery Life in the App.

I figured Eureka and then tried the Keypad again and this time it changed the SHM status.

Not entirely certain why it behaved this way. So far mine has stayed paired and has been working fine.

I did not perform the Factory Reset on mine. I never had to. Not that this should matter.

Seems to me if it is working for you then later loosing connectivity you may have a hardware issue with the Keypad itself. Or weak batteries. I am only guessing.

Thanks to everyone for the help. Sadly, still no luck yet.

I just received the Xfinity version of this keypad, and gave that a shot. Pretty much the same thing. It seems to pair, but if you enter any 4 digits followed by an arming button (Away, Stay or Night) it gives an error beep and all of the arm lights start illuminating and cycling back and forth. At that point, it will reflect the SMH status, but it does not respond to any keypad input whatsoever.

I’ve tried Ben’s new device type with the Iris version of the keypad and get the same results. I tried a lot of variations of jgravert’s pairing process without success as well. Rebooted the hub a few times and removed and re-installed the device types and smart apps as well and none of that made a difference. I might have to pass the torch here as I am running out of ideas.

Here’s a short video showing the issue I am having:

Centralite Smartthings Pairing Issues

K so I reproduced your video with my working IRIS keypad. I’m using the 3400-x Keypad manager, and the user lock code manager apps and the Centralite Keypad device handler. Also Smart Alarm and just SHM for mode status only.

The green light on the right corner should not be flashing. I would delete everything and start from scratch. Looks like it didn’t pair fully.

Link to working Video

1 Like

@jparchem have you moved the keypad since you paired it? i.e. were you close to the hub when you paired it, then moved the keypad to where you intend to use it? I had issues successfully pairing mine until I tried pairing while it was already in place next to my door. Now I actually have two that are working fine. Can’t say for sure if that’ll work for you, but you might want to try unpairing and then giving it a shot.

1 Like

@jparchem, I was setting up my new second unit soon after you started having this problem. I was suddenly anxious that I had another epic battle beginning with a new device but lucked out with a good random idea that got it working as intended. I noticed it looked too much like your video up to a point.

So I did exactly what you did and was ready to test when I noticed the flashing green “wifi” light (guess that is what it means). I knew that was not normal and wanted to resolve it before testing. I simply removed one battery of the two in there and put it back in. Light stopped blinking and stopped being lit. I did a test and it all worked great. Likely I first used the mobile app and clicked Refresh on the Keypad device interface before testing. I am finding that is always seeming necessary at some point anyways.

So if you get into this state again, try that.

1 Like

Hi Mark-

I’ve been trying to pair it close to the hub to avoid any distance issues. Never have gotten it to pair regardless of where it is. Thanks for the tip, though!

Thanks for trying it out, Bernie. Are you using a version 1 or 2 hub?

Sorry V2.

20 characters

1 Like

@TanquerayG - Thanks a bunch for taking the time to reply. Unfortunately for me removing one battery didn’t stop that blinking network light. I even tried swapping out different batteries.

At this point, there might be something unique about my hub or something that only myself (and perhaps 2 others) have the issue and no one else does. I might try firing up my old hub at some point, but honestly I’ve got to put aside this project for the time being.

Again, I do appreciate the help and suggestions!

1 Like

Could someone send me a link to the latest device type and smart app with instructions for IRIS Centralite. This forum is a mess finding anything. I will be using this with Smart Alarm so I need settings for that also. I wish we had a complete project page. This forum is lacking, as no one knows which is the latest code and for what device.

1 Like

Git repositories will be the latest for the vast majority of smartapp’s and device types, some folks might post modified versions directly, but as a general rule at the beginning of a device thread or shortly into it, you should see a Github link.

For example a quick 30 second scan of this thread, just looking for links, found this:

or this:


and device type:


Also, if you know the author of the app/device you can search them on github to find their repository of everything.

I have a separate favorites folder just to keep these in to keep it easy. You can also bookmark posts that you want to return to with the little flag next to the Reply option of each post

Not to sound stupid, or at least try to not to. In order to use this with Smart Alarm I need 1. Smart App
2. and device type:


Ok is that correct and is there a place for the actual instructions. I now to install the apps I go to IDE and for the app I select new from code and paste the code and publish for me. and for the device type the same basic way correct?

Yeah. So make sure you get your head around how these things work. It’s like this:

  1. Install a device type for the device you want to use. In this case the link you provided from Mitch Pond. This lets ST “talk” to the device. You do this in the IDE under “My Device Handlers” click “Create New Device Handler” and paste the code in via the “From Code” tab.

  2. Install the SmartApp that controls the device. Either User Lock Manager like you linked, or the original x3400 one. Same thing in the IDE, click “My SmartApps” then “New SmartApp” and paste in the “From Code” tab.

  3. If the device has not yet been added, do so via the smartphone app via the three dots upper right and then Connect New Device. If it detects an unknown device you always want to go into the IDE, under “My Devices” and click the unknown Thing, hit Edit at the bottom and choose the correct device type.

  4. In the smartphone app, do Connect New Device again but choose SmartApps, at the bottom of that list should be My Apps, and your custom SmartApps will list under there. Choose User Lock Manger or the other one and set up per the screens that follow.

I think that covers it, I just went through the motions as I typed that so it should be accurate.


Thanks. OK would you know which of the two Lock Manager or X3400 works best with IRIS pad and the Smart Alarm? It does work with Smart Alarm correct?