Can't update icon for Things

I am having the same problem. It appears random why some icons can save, and other cannot.
Using the iOS app.

I have the same issue with my Android app. It’s definitely a widespread problem.

I have the exact same issue as the OP - in my case I’m having the problem with both GE Smart Dimmers and GE Smart Switches - but, like the OP, not with my Cree Connected Bulbs.

UPDATE: I received an email from support saying this was a known issue that they are working on.

In case it helps…same issue with GE Z-Wave switches and Hue bulbs.

hopefully we see a fix for this soon its rather annoying!

Same issue with NEW app on Android 5.0. I have an extra old Android device that I did not upgrade to the new version of the software and I CAN change icons with it. I have added a half dozen or so GE swItches and outlets since the new software was released and using the old version of the software has been the only way I could change icons.

I also see quite a few “hangs” and crashes with the new android app. The most recent release is better but they are still occurring. I haven’t tried changing icons with my wIfe’s iPhone but I have noticed that the iphone software is stable and does not crash like my Android does.


It was pretty janky, but this was helpful. All my devices are on 2.0.3 (including my iPad), but I was able to download 1.7.6 from apkmirror, run the APK in Chrome, and change the icons. Difficulty–the icons don’t SHOW for me in Chrome, so I had to look at the icons on my tablet, then click in the right “place”. Took some trial and error, but it worked. Don’t recommend this a solution, however…

I can’t get any of my device icons to change either. Leviton switches, hue bulbs, GE outdoor modules. Frustrating.

1 Like

Just chiming in to say I have the same issue on Cooper Wiring Dimmer Modules. They appear as an outlet icon but work fine otherwise.

Would like to see an official response from support on this. Known issue for sure as I’m also unable to change the icon for all devices in my network, but is there an ETA for this bug fix?


In addition to having the inability to change icons on my Android devices, I also sometimes see duplicate pages of a given device. By this I mean that when I navigate to a device I can scroll down and see the same device properties listed twice.

This was a know issue to me. Yesterday I tried, for some reason and it worked. I’m on Android 6.0 on the latest ST app.

Just discovered this issue. If I change a device icon in the Classic app (Android), it just shows a circle on the “My Home” screen but shows properly in the new Smarttings app. I sent an email to support…

Also, I can’t see how to change the icon in the new app?!?!

Support replied to my email - said to reinstall the classic app.
Now there are no icons in any of the categories when you try to update an icon and all of the icons are round circles on the “My Home” screen.

They obviously don’t test the apps before releasing them.

I downloaded the 2.17 version and installed it. Everything appears to be back to normal!!!

Got another email from support

This is with regards to the issue that you are facing with the classic app not updating the device icons, we have confirmed it and want to let you know that it is a known issue that is being investigated. We don’t have a timeline for a fix at this time, but could be in an upcoming version update.

I’m not seeing very many icons as options. And some icons can be selected but don’t actually update on a device. Hopefully a fix comes soon. My OCD is killing me.

I don’t see any icons at all. How did you find version 2.17

I have 2.18 loaded on a LG v930 tablet, android ver. 6.0 and a Samsung phone SM-A600A, android 9. Icons are visible on the tablet and only 4 in Lighting; 20 in Office on the phone. All other categories are blank. There a place holders but no icons. If I change them on the tablet, they show up on the phone.

A post was merged into an existing topic: Chaning Icon’s in the Smartthings App not working (May 2023)