Can't Reorder Rooms in SmartThings Android Mobile App


(ocpd+adhd+alz+md+hfa+fms+lol=me :)) #1

I have always been able to reorder my rooms, but the other day, I created a new one, and it wouldn’t allow me to reorder the list to put the new one where I want it.

Also, as I was creating it, I got an error message. So, I tried to create it again, and got the same error. Then, I backed out to take a look, and noticed that it actually created two of them…of the same name. So, I deleted one of them (it allowed me to do that, even though that also threw an error), and now I just can’t reorder the remaining one at all.

It allows me into the reorder page, and I can move it to where I want it in the list, but then, when I click Done, it gives one of the following two errors (one one time, the other one another time…no idea if there is any specific reason for either of them)…
“You appear to be having issues with your network. Please check your network connection and try again”
“An unexpected error occurred”

I rebooted the router just in case it was causing any trouble (even though I had already done some testing and found the network to be fully operational). So, I really doubt it has anything to do with my network here. Is there any chance this is related to the updates that were just announced recently?

Then, after hearing back from Support, I removed the new one, and tried reordering, but it wouldn’t work (i.e. can’t reorder, regardless of creating a new one or not).

I then force-closed the ST app, and went in to try again.
Now it won’t let me reorder any of them. I get to move one, and it looks right until I click Done.
Then it gives the error. Then, I click Back.
Then I go in to try to reorder again, but no love.
Then I force-close again and go back in, but still no love.

Just FYI, I just went back in and created another new room, and got the same problems (just to say it’s still happening as of the time of posting this).

Any idea when this will be figured out and fixed?

Is there any way to reorder rooms via the IDE?

NOTE: I created a support case for this, but I’m not sure if they’re still looking into it or not. They asked for timestamp to look for in the logs, and my account e-mail address so they could look into it on my account. No response since I gave them those pieces of info that they asked for, and no idea where that is now.


(Andrew) #2

Everything you describe here is also happening to me on iOS. I seem to recall the problem creating a new room as being a known issue. The workaround is to do as you reported: create the room, try to hit done, fail with an error message, then back out. Your room will be there just like you asked. :wink:

I reported the problem with reordering rooms on iOS, and support said it was a known issue with no known workaround.


(ocpd+adhd+alz+md+hfa+fms+lol=me :)) #3

Right, but the problem is that, even with that routine, it still sometimes doesn’t work.

Thinking about one specific room…
On Day0, after many attempts, I can get it created, and after many reorder attempts, I can get it to move about 3 or 4 spaces, but just doing it one at a time.
On Day1, I can get it to move a few more places, but still only one at a time, and only after many attempts
On Day2, same thing…and on and on…
Now, on Day3, it won’t move even a single place, after many attempts, and it’s just stuck there now, in the middle of the list; whereas I want it way down near the bottom.

So, no, I’m sorry, but there is NOT currently an actual, usable, effective and reliable ‘workaround’.


(Andrew) #4

I’m not arguing with you. If you re-read my post, you’ll see that I said there was no workaround to reordering rooms.


(ocpd+adhd+alz+md+hfa+fms+lol=me :)) #5

Doh! :slight_smile:


(ocpd+adhd+alz+md+hfa+fms+lol=me :)) #6

UPDATE: just FYI, it’s still not working. In fact, now I’m not able to reorder any rooms at all. When I go there, none of them will move at all; the list just scrolls.

I know they have this on their list and are going to be working on it. So, not heaping here…just an update.