Can't remove Magic Home

I am trying to remove Magic Home app from Smartthings and I am getting " an unexpected error occurred" error. Please Help…

Have you confirmed that all devices have been removed from the app? Have you tried to remove it from the IDE?

If you have done both, then have you contacted support?

Have you enabled your developer account? If so go to locations and you should see SmartApps section with an edit button once you’re in your correct “location.” I’ve seen using that to delete SmartApps have a little more power than in the Smartphone app.

Sorry if the post is vague, I just don’t know how much you know already.

If none of these suggestions work you can contact our support team. They can work magic.

I installed an app through the IDE once that required OATH to be enabled. I didn’t enable OATH, so when I attempted to uninstall the app, I got the “unexpected error” message. Once I enabled OATH I was able to delete the app.

Thanks. I have tired to remove the 2 iphones I have connected to the app and when I do it would not let me save the setting in the app. “Opps! Looks like you need to double check some settings”. So it needs something to monitor. When I try to remove it from the IDE channel I am getting “This SmartApp can’t be deleted at this time because it is installed by one or more users”. I have tried to enable the OATH setting but that did not help.

I have just sent support a request. Thanks guys.

Having the same issue, trying to update to the published version of the app, because magic home seems to have been running in modes that I had not chosen in the settings.

Same here, magic homes has been working funny since yesterday…

Having the same issue here. Trying to uninstall Magic Home so i can install the official version SmartThings app (Hello Home Phrase Director). I contacted support this morning. Enabling OATH didn’t with for me.

Support should be able to help you. Then had to send it off to the engineering team to remove it.

Magic Home is the old old old version of the app. Please grab the newest code and then you will be good :smile:

It’s now called Hello, Home Phrase Director.

I am having the same problem with Magic Home Mode. I can’t delete my old location after switching to v2 hub because of this. Same thing happened last time i did a v1 HUB swapped. Support said they need an engineer to delete it last time so I am waiting for them to do it again this time.

I’m the guy who wrote the app. You need to replace the custom code with the most recent version. Then the uninstall is easy :slight_smile:

I was having the same problem and replacing the code first then removing it worked fine. I then installed the Hello, Home Phrase Detector .
Thanks @tslagle13

1 Like