Can't get Fibaro Dimmer 2 to work


#1

So, I’ve got the dimmer 2 installed behind a light switch.
I turn on the mains power, and the lights come on. They flicker around a bit as it does its calibration.
It’s all paired with SmartThings OK.
I can see it in my app, and see it in my Device List on https://graph-eu01-euwest1.api.smartthings.com

I’m using the “codersaur : Fibaro Dimmer 2” device handler for it.

I can’t turn it on or off though, using the app or switch :frowning:

I’ve got standard UK switches, so I believe I need to update parameter #20 (switch type) to 1 for toggle switch.
the Device List shows this is set accordingly.

Any ideas as to what I’m doing wrong here?

The App shows a “Sync Pending” message, which just wont go away - is that the problem?
And the website shows:
Date Name Value Units
2018-02-24 4:41 PM GMT - 6 days ago syncPending 8
2018-02-24 4:41 PM GMT - 6 days ago syncPending 9
2018-02-24 4:41 PM GMT - 6 days ago syncPending 8
2018-02-24 4:41 PM GMT - 6 days ago syncPending 9
2018-02-24 12:34 PM GMT - 6 days ago syncPending 8
2018-02-24 12:32 PM GMT - 6 days ago syncPending 7
2018-02-24 12:26 PM GMT - 6 days ago syncPending 1
I don’t know what that means…is it saying there are multiple things pending sync? What does the value mean?

HELP :slight_smile:


(Bob) #2

Is it turning on then off straight away?
Edit:I’m using the same DH BTW.


#3

Once i’ve turned the powe on, the light turns on and stays on, and I can’t switch it off again.

Just tried deleting the device and readding again, but same problem.


(Robin) #4

Are you changing the parameter preferences via the app or the IDE?

I think it needs to be done via the app to trigger the sync.

Also, any logs when trying to control via the app? Specifically any errors relating to zwave secure?

It’s fairly common with these devices to add themselves to the hub as an unsecured device and that stops the DTH from working.

To get a secure connection, the hub and device need to be within 1 meter of each other during inclusion… I normally bench test each new device next to the hub, then move it to its proper location and run a zwave repair.


#5

I’ve updated parms via the app, and the IDE…neither seemed to have worked.
It’s a little fiddly through the App, because you can’t save a single parameter, you have to update a bunch of mandatory ones too.

I’ve also gone into the white menu option, which allows the B-button to be used to turn on/off, but that doesn’t do anything.


(Robin) #6

Please post live logging from when you click on/off in the app.

Also logs from when you click ‘done’ for preferences in the app.


#7

The top event is when I turned device off. The app said “Turning off”, but nothing happened. About 1 minute later, the app just said “ON” again.


(Robin) #8

that’s the device log… true info is in the ‘live logging’ tab

Nevertheless… there is a clear error message there saying ‘secure inclusion failed’ as I suspected.

Remove the device, move it (or the hub) within 1 metre of each other and re-include.


#9

Brilliant…thanks, I’ll try that out.
I did see that error…but thought maybe it was “normal” for the secure inclusion not to have worked, but it had included it in a non-secure way…or something like that :slight_smile:

Right…time to get extension lead out.

Wonder why I didn’t have to do this with my other dimmer 2, located slightly further away in a ceiling rose?


(Robin) #10

Secure inclusion is only achieved when the device and hub are talking directly during inclusion.

If any repeaters sit in the middle, the Fibaro will latch onto the repeater instead of the hub and secure inclusion will fail.

The 1 meter guidance is from the Fibaro manual… but in reality it could be a much bigger distance, so long as a repeater doesn’t get in the way.

An alternative to getting the extension lead out is to power down other devices in the middle… but that’s not always easy to do if they are on the same power ring as the device you are trying to add.

I have a test rig with a mains plug and a bulb that I use for inclusion near the hub before I move the device to its final resting place.

Either way, wether you move the hub, the device or power down repeaters to achieve secure inclusion, you’ll still need to run a zwave repair after putting things back the way they should be, to rebuild the neighbor tables and achieve a strong mesh network.


#11

Ah, ok, that makes sense, and probably explains why moving didn’t help. Something else getting in the way.
I can power off my other devices easily enough, and try again.

How is the zwave repair initiated?


(Robin) #12

In the ST app, click the hamburger button on the bottom right.

Click ‘hub is online’

Click zwave utilities

It can also be done from the IDE but I like doing it from the app as you can (usually) see when it’s finished.

Make sure everything is powered up during the repair, try not to turn things on/off.

Not sure if it helps or not… but I always try to trigger battery devices to wake up so they can be included in the repair (I.e. open contact sensors, trigger motion, push buttons)


#13

everything turned off, bar 1 other dimmer2, that’s double the distance from the Hub.
Still getting same error though.
Is there anything else that can cause “Err 106: ZW secure inclusion failed”

Wait, I suppose it could be my Hive heating stuff…i’ve power the hub off, but the boiler control itself (in another room) is still turned on.


(Robin) #14

I don’t know much about hive but if it’s zwave, mains powered and directly connected to ST without a bridge, then it’s possible.


#15

Hive all works from their hub, which is off.
Just can’t get it to not have that error.
Only thing I’ve not tried is removing the dimmer 2 in the ceiling, and powering off the Hive controller under the boiler.
Giving up for today and getting some lights rewired :smiley:
Robin - thanks for all the advice.
I’ll try setting up some temporary wiring tomorrow so I can power the dimmer 2 from an extension lead, and literally put it on top of the ST hub.


(Robin) #16

Why not move the hub… it’ll run on battery so you just need a long Ethernet cable.


#17

Yeah, that’s my problem - no long ethernet cable. Well, I have a long one with the end chopped off, will need to add a connector on the end. I’ve got the tool to do that, might be easiest way.
I’d forgot the hub can run on batteries.