Can't delete a location keeps giving error, any suggestions?

I have 2 locations and had 2 Hubs. I’m trying to delete one location as we don’t use it but not having any luck. If I use the mobile app it says “Something went wrong, we are unable to remove your location, please try later.” I’ve been trying for days, it always says that message so not sure how much later I need to wait. In IDE I deleted the Hub from the location which worked but I cannot delete the location itself. When I click delete it just says:

Oh No! Something Went Wrong!
500: Internal Server Error
Reference Id
Sun Apr 15 12:58:39 UTC 2018

There’s no SmartApps, Device Handlers, Devices or anything in IDE under this location. The Hub has been deleted just the location won’t delete no matter what I try.

Edit: I figured it out, it was because it was set as the default location so changing that fixed it!


same issue I have one hub two labcations I don’t know how to delete it?

You can contact ST support and they can help you…

Thank you, this worked for me! I had multiple locations and somehow the one I was never using was set to default. Following your instructions I was able to succesfully delete it.

Changing the default location worked for me too. Thanks. A less cryptic message from ST would have been much better than having to find the answer on a forum.

Hmmm, the flags as described, but I was unable to change. Old location is permanently true, new one changeably false. But when I change it to true, I can’t save. There is nothing, including hubs associated with the old one.

1 Like

You may want to login with an incognito/private tab in your browser.

In order to delete a Home Location that has nothing in it:

  • Login to IDE at
  • Goto Locations
  • If you have multiple Locations, select the invalid one
  • Make sure there is no Hub associated to it
  • Scroll to the right and click Edit
  • If the Default Location shows “true” (will be read only)
  • If it is “true”, go back to Locations and select your primary (Real) location and set the default location to “true”
  • Now you can edit/delete the additional Home location as it will automatically be set to “false”.

If that fails to resolve the issue, contact ST support and they can do it

1 Like

Thanks, but no joy. Just won’t let me update primary (real) to true. Or more precisely, it appears to, says saved, but doesn’t actually save.

When did your account migrate to Samsung?

I have the same problem and it won’t save the update from true to false. Any other suggestions? Samsung said there is nothing they can do but it’s annoying having a useless location.

I have the same exact problem, when changing the actual active one with the hub to true and clicking update doesn’t save the new setup and the old one remain the default one - any other ideas?

1 Like

Worked! Thnx a lot!

I was going crazy with this until I found about the Default Location that was set to true. Thank you very much.

1 Like

@jkp thanks for the help. This was driving me crazy!

1 Like

I have the exact same problem. Making other locations the default location doesn’t actually save and I cannot delete the default location with nothing in it. Were you ever able to get this working? Thanks in advance.

Unfortunately both locations are set to true and cannot delete one.

Did you try editing the location with the hub/devices and click the on update, which would then change the other to false?

both are unable to change from true to false

Try this…

Otherwise, you will need to contact ST support @