2 Locations and 1 won't delete


(John G) #1

Hi my app is showing 2 locations, when I try to I load a new “new smartapp” (Sensibo from code) the app seems to always attach itself to the location I am trying to delete.

I have tried to delete the old location but get the following message.

Oh No! Something Went Wrong!
Error
500: Internal Server Error
URI
/location/list
Reference Id
237501ec-9ad2-4604-8e42-41bad5d0fb0c
Date
Sat Jul 07 05:51:22 UTC 2018


(jkp) #2

try using an incognito/private tab when logging in to IDE @ https://account.smartthings.com

If that doesn’t resolve your issue, report back as there is another thing to try.


(John G) #3

Tried it through the supply link but still getting the same error


(jkp) #4

OK, try this to delete a Home Location that has nothing in it:

  • Login to IDE at https://account.smartthings.com
  • Goto Locations
  • If you have multiple Locations, select the invalid one
  • Make sure there is no Hub associated to it
  • Scroll to the right and click Edit
  • If the Default Location shows “true” (will be read only)
  • If it is “true”, go back to Locations and select your primary (Real) location and set the default location to “true”
  • Now you can edit/delete the additional Home location as it will automatically be set to “false”.

If that does not work, please contact ST support at https://support.smartthings.com :slight_smile:


(John C) #5

Many, MANY folks have experienced this issue. A search of the forum should turn up a number of similar threads…

What @jkp suggests is sound advice & he has helped many in similar situations. Hopefully, those suggestions work for you. If not, contact support as he suggests.

Good luck!