2 Locations and 1 won't delete

Hi my app is showing 2 locations, when I try to I load a new “new smartapp” (Sensibo from code) the app seems to always attach itself to the location I am trying to delete.

I have tried to delete the old location but get the following message.

Oh No! Something Went Wrong!
500: Internal Server Error
Reference Id
Sat Jul 07 05:51:22 UTC 2018

try using an incognito/private tab when logging in to IDE @ https://account.smartthings.com

If that doesn’t resolve your issue, report back as there is another thing to try.

1 Like

Tried it through the supply link but still getting the same error

OK, try this to delete a Home Location that has nothing in it:

  • Login to IDE at https://account.smartthings.com
  • Goto Locations
  • If you have multiple Locations, select the invalid one
  • Make sure there is no Hub associated to it
  • Scroll to the right and click Edit
  • If the Default Location shows “true” (will be read only)
  • If it is “true”, go back to Locations and select your primary (Real) location and set the default location to “true”
  • Now you can edit/delete the additional Home location as it will automatically be set to “false”.

If that does not work, please contact ST support at https://support.smartthings.com :slight_smile:


Many, MANY folks have experienced this issue. A search of the forum should turn up a number of similar threads…

What @jkp suggests is sound advice & he has helped many in similar situations. Hopefully, those suggestions work for you. If not, contact support as he suggests.

Good luck!

1 Like

I have the same problem but the invalid location was already on False for default location, I tried to make True and then make the valid one True to automatically make the invalid one as False but did not work also, it keeps giving me the message of " ACCESS DENIES We’re sorry, but you are not authorized to perform the requested operation. " I have two account associated with this location although both are with the same email address, I think one for Smartthings account and the other for the Samsung Account, I tried to change the associated account as well but also did not work

I discovered I had two locations and also tried in vein to remove the unused one myself. In the end I just contacted support on a live chat and they sorted it out in seconds.
I’ve seen a thread moaning about support from SmartThings recently and couldn’t disagree more from my own experience. The three or four times I’ve needed to use it they’ve been nothing short of brilliant, in fact the support has been the best online support I’ve ever had from any company , bar none