Can't control Centralite Pearl Thermostat Temperature with routines

Okay, so I have an update. I noticed this morning that the ST app was updated to version 1.6.94.9 and that the device driver version was updated to version 2023-01-18T18:59:26.357805918. So I decided to try again. I created two simple routines; one to turn the temperature down and the other to turn it back up at predetermined times. And would you believe it, they worked. This is not saying the problem is resolved as this is a very small sampling. I’m going to delete my older routines as these do not seem to work still and recreate them and will see if those work and report back.

The first step will be to recreate the overnight routine to lower the temperature followed one to raise the temperature back in the morning. If these two work, then we can move on to recreating the routing that is supposed to lower the temperature when I leave for work, followed by one to raise the temperature when I am leaving work for home.

If those hold up, then we might have turned a corner and we can move back to the more complex stuff, like lowering the temp when it gets too hot!

Now my Pearl thermostat is acting up. I can set the cooling temperature, but now I can’t set the heating temperature from the SmartThings app either manually, via a Scene, or an Automation.

No change for me. Still works only intermittently. Seems like it’s more likely to work when increasing the temperature for some reason. I don’t use automations. I just try to adjust it in the app or via Alexa. I actually seem to have more luck using Alexa.

It looks like they have finally stabilized it. After a week all my automation have worked. I am running version 1.6.95.25 of the ST app and version 2023-01-26T18:09.32679632 of the driver. What I did notice in my testing though is that it seems like it does not like whole numbers … so in stead of my automation setting the temperature to 68 degrees for example, I set it to 68.2 … (don’t know if that has changed now and don’t care to find out since everything is working).

So I have three automation which run based on time (when to turn down the temperature and when to turn it back up) and one based on location, i.e. when I have left for “x” amount of minutes, turn down the temperature. For all three, I also have an automation which send me a text confirming the temperature change, this way I know that it is running.

So if you’re still having issues, see if updating to the latest version of both and having it set to non whole numbers works. I will add that when using Alexa (which is not that much for setting the temperature), I use whole numbers and it seems to work fine. The 68.2 degrees thing is when I’m writing an automation or setting the temperature manually in the ST app.

Hope that helps

Are you on Android? On the iPhone, I only have the driver from 01-24, with no way that I can see to force an update.
Also, on the iPhone app, there is no way to increment the temperature in anything other than 1 degree increments, although the app now always changes to a 0.2 degrees after the temperature (so if I want to set it to 68 degrees, the app makes it 68.2, and if I increase it again, the app sets the temperature to 69.2).
My ST app version is the same as yours.
With this version from 01-24, the problem still persists. Sometimes it works, sometimes it doesn’t. Maybe when it eventually updates to the newest, the issue will be resolved.

I’m on an iPhone, IOS version 16.3. The driver should be pushed to you automatically once available. I did have to uninstall the ST app (for a different reason) and reinstall it, maybe that had something to do with it? Are you using the Zigbee Thermostat driver from SmartThings?

You can increment the temperature if you tap on the numbers (as opposed to the + or - buttons) and type in your desired temperature, but yes it has to be in one degree increment. However, I will say, over the past few days it has worked for me even if the temperature is 68 or 68.2. However, since I felt that the whole number were causing an issue with the automation, I just kept adding the decimal.

Hopefully the update will be pushed you soon as that might take care of the issue.

Yeah, the thermostat is using the Zigbee Thermostat driver from SmartThings. Mine is still the 01-24 version.

I didn’t know you could tap the numbers to adjust the temperature in smaller intervals. That’s cool.