Can't control Centralite Pearl Thermostat Temperature with routines

So I have a Centralite Pearl Thermostat. I can create a routine to turn the heat on and off, and that works fine. However, when I create a routine to change the temperature (for example when I leave for work or over night) nothing happens it doesn’t, the routine does not change the temperature. I can change the temperature manually in the SmartThings app and I can even ask Alexa to change the temperature, which both works … the problem is a routine that changes the temperature … even if the routine is as simple as “at x time, set temperature to x degrees.” it has no effect … I even tried creating a scene to change the temperature, this did nothing.

I’m running version of the SmartThings app and the device is using the SmartThings Zigbee Thermostat driver, version 2022-11-22T20:04:04.50490979.

Anyone else having this issue or have any ideas?


A few months ago, I deleted the Peral and removed the SmartThings Edge Beta Zigbee thermostat driver when they made the Pearl available using the production Edge Zigbee thermostat driver. So I re-added it so I’m currently running (2022-11-22T19:58:01.471867129). I don’t have any Routines that change the thermostat temp, but I just created a quick test Routine using at Time as the trigger and it changed the heating temp on the Pearl from 69 to 68. I then changed the at time of the test Routine to set it back to 69, and it did.

I had deleted and re-added the Pearl device a few weeks ago for a different issue, but it was such a pain in the rear to added it back, so I don’t want to delete it again if I don’t have to. That said, how do I get a hold of the “production Edge. Zigbee thermostat driver?”


I’m not sure if you mean by ‘added it back’ whether it was re-pairing it to the Hub, or setting up all the Routines/Scenes again. As for the Routines/Scenes, what I did was use @TAustin’s Edge virtual thermostat driver which I put in all of my Routines/Scenes with the same settings as the Pearl thermostat so that after I re-added the Pearl thermostat, I just re-added it to all of my Routines/Scenes that the virtual thermostat was configured using the same settings. It was just a little time consuming, but was painless.

The SmartThings staff on this community advise the only way to get the production Edge driver if using a Beta or third party driver is to delete the device, unsubscribe from any Edge beta/3rd party drivers for the device, and re-scan to add the device so it can then install the production driver. The SmartThings staff also advise that the Beta and production drivers are the same, BUT on two device occasions, the Pearl thermostat and the AEON Minimotes, I’ve found that NOT to be true. In fact I’m still running the Beta driver for the Minimotes since the production driver was totally different from the Beta driver the last time I tried it.

I have the same problem with my Centralite Pearl Thermostat. It won’t respond to my automations to change the temperature at certain times. Your explanations are a little over my head. What is meant by re-scan the device? Just have the hub look for the device after unpairing it from the network? I did that and nothing changed. I re-inserted the re-paired thermostat into my automations and they still don’t work. What next?

Might be related to this:

Thermostat problems (multiple brands) Nov 2022

I’m also having the same issue. I can control the operating mode and switch the fan between ‘auto’ and ‘on’ (even though the thermostat doesn’t control a fan), and if I change anything on the thermostat itself, the change appears immediately in the app, but if I change the temperature in the app, most of the time I get a spinning cog for a few seconds and then a “network or server error” message (it does occasionally work correctly).

I’m reading all these posts about adding drivers and handlers. I’m confused. I thought the IDE was deprecated? I thought the only choice was what was presented to me on the Smartthings App when I paired the device? Are there workarounds to get custom code into this new locked down Smartthings environment?

You get your custom code by downloading Edge drivers to your hub via email invitations. There are many community members writing and sharing the Custom Edge Drivers that they develope.

You can go to GitHub and download the ST Beta Edge Drivers and modify them yourself if you are so inclined.

The new system is not locked down it is just different.

Search this form for Centralite Pearl and see what is out there. In most cases ignore any post more than 18 months old.

Device Type Handlers are part of the old architecture and are no longer available.

Edge Drivers are part of the new architecture, and just like the old architecture, there are both stock versions provided by smartthings and custom versions created by community members. But you add them to your account in a different way and you don’t use the IDE for them.

See the community FAQ. It should help clear up the confusion.

FAQ: I have no idea what Edge is. Is that a new developer tool? (2022)

I just noticed my thermostat seems to be working with my automations correctly today. I checked in the app, and it shows a driver version of 2022-12-20.

1 Like

Mine also seems to be working consistently again.

And now it doesn’t work again.

Do you know which channel your are subscribed to? My version is 2022-12-13 (see attached) and it’s still not working.

If it’s any consolation, I still can’t get mine to work … at least getting it to change the temperature in a routing.

I’ve been using the SmartThings Edge Production Zigbee Thermostat driver (current 2022-12-27T19:30:07.497436529) on a SmartThings Hub v2 for months with my Centralite Pearl thermostat. Every time I setup an Automation (on both Android and iOS) to change the Heating temperature when the thermostat is set to Heat mode using SmartThings Automations with just a specific time as the trigger, it works.

Mine driver doesn’t list a channel, so I suppose that means it’s the release version and not the beta. Also, my driver version is from December 27. It works only sporadically. I don’t even use routines for the thermostat. Just trying to set the temperature in the app sometimes works and sometimes doesn’t (it just spins and spins and never adjusts the temperature).

Is this working now for anyone? My Centralite Pearl thermostat also isn’t setting temperatures in routines and mostly even manual temp adjustments don’t work in the app. I’m on a V2 hub and edge driver.

Still not working for me and to be honest, I’m not ready to remove the device and add it back as it’s a pain in the butt to add as Centralite doesn’t make it easy (I did it once before). I have just been quietly waiting and hoping that it will be updated.

Right now I can get my routines which turn it on and off to work, however, any routines which set the temperature isn’t working.

Sometimes it works and sometimes it doesn’t.