Can't add back Smart TV

Hello,

I am struggling to get my Samsung Smart TVs added back to SmartThings after I deleted them in an attempt to fix another issue. Before that, they were successfully connected to SmartThings.

UN65KS9000GXZD - SmartThings app can not discover it anymore. The only way to somehow connect it to SmartThings is to factory reset it and log into my Samsung Account. However, it is remains INACTIVE having no Device Network Id assigned to it, and the device type is set to “placeholder”.

UN43RU7100GXZD - SmartThings app is able to discover it and complete the pairing, so there is no need to factory reset it. In this case, the device is shown as ACTIVE, but the Device Network Id is not assigned and the device type is set to “placeholder” as well.

Being my TVs inconsistently linked to my SmartThings account, they can not be detected by my Home Automation set up using Home Assistant on a Raspberry PI.

Can someone please assist me?

1 Like

The “placeholder” device type is expected following a recent change where TVs are no longer backed by a Groovy-based device handler.

Are you able to control the devices in the SmartThings app? I’ve not heard or seen of the issue with the UN65KS9000GXZD. You’re fully factory resetting the device where it reboots?

how recent? My TV from the end of November still uses Samsung OCF TV. Any advantage to the new method?

I believe early to mid December.

I think the new integration still works with voice assistants but may be broken with some Groovy integrations.

I had an issue with a “placeholder” setting as well. I sent a message to Smartthings about it, and the next day, it was gone. I don’t know if they fixed it (no response) or if it fixed itself.

Did you exclude the TVs, or simply delete them?

Im having a very similar issue to the above.
My TV appears as “placeholder” and “INACTIVE”

I have tried to delete and pair again form both the app and the tv, I have done a factory reset of the TV and am not getting anywhere.

I have spent multiple hours on the chat with the smarting support team who referred me to Samsung support AU who seemed to have no idea what I was even talking about…

Any help/advice would be appreciated.

The question is… are you able to control the TV from the ST app?

Yes, I can control the TV from the ST app.

Anyone was able to figure this out? I just got the new 2020 The Frame tv and experience the same issue but my older tv from 2017 shows up correctly. Also the events log under the device are about 2 -3 hours delayed is that normal?

Q80T, same problem. It was fine and I could control it from Home Assistant, but 4 days ago it stopped working with the same symptoms :frowning: