Cannot install a deployed SmartApp in Developer Mode on Android


I’m working on a “Webhook” SmartApp. Everything’s configured in the Developer Workspace and the app is “Deployed to test”. On the Android app, I enabled “Developer Mode” and try to find the SmartApp in the “Discover” function of the “Routine” tab.
This may not be the right place, because there was some changes lately and documentation may not be up to date. But the Discover panel opens and never stops searching or loading the page (with the 4 dots turning in the middle of a white page).

I tried this on two different devices: a Galaxy S23 and a Galaxy Tab S6. I also tried deleting application’s data and starting over. Also I think this function doesn’t work for a long time.

Am I doing something wrong, is the Discover page under maintenance, is there another way for me to install a deployed SmartApp?

Thank you

I’m going to say ‘no’, ‘no’ and ‘no’.

The Discover page should list a number of routine templates, plus ‘Smart lighting’ in SmartApps if available in your region. If you are in Developer mode it should also list your published apps. It’s not really doing anything that should break so badly.

Thank you for the confirmation. I also tried on my GF’s phone, a Pixel 4a, whith her own Samsung account linked together. Same result.

Does this Discover page (the one under Routines) work for anyone? I think it doesn’t work for months for me, but I didn’t pay attention before before I didn’t need it.

I forgot to say I have a Webhook SmartApp installed and the Discover page works fine.

Hi @Konnichy It is strange we don’t have reports about it, I tried with a Pixel 4a and it is working fine.

Could you share evidence about what is happening?

Sure. Here it is:

I cleaned all installed apps even though the only one I had worked flawlessly for a long time. I also cleaned everything in my Developer Workspace (projects, devices profiles). And listed every possible command with SmartThings CLI to check whether there is any leftover.
The result remains the same.

Sorry for the delay, it seem to be a problem with UI, this week a new version was released please Could you try with the new version?

Thank you for following this matter.
I tried with v1.8.11.25 of December 7th, but it’s still the same. With developer mode enabled or not.