Cannot Delete Device on App

Latest version of SmartThings app on my Samsung Galaxy S22 Plus. I have an old z-wave device (a wall dimmer to a chandelier) that I cannot delete. I have tried long-press delete and also using the remove devices where it list all of them and you click the device - sign to delete. The page flashes but is still there. I don’t see a way to login online anymore to do this. Any ideas? The light comes on in the evening and later goes off. The problem is I have looked at all of my routines and don’t see any that are at fault so my final choice was to delete it and it slowly add the routines back in. Anyone with tips on how to delete the device?

  • IDE go to My Locations first and tap on your location name, then proceed to My Devices.
  • API Browser+ probably better to use this tool rather than IDE.

if those do not work, come back and we can give you more options :slight_smile:

1 Like

Look at the device history to see what time it comes on. Then look in the general ST history to see what was triggering at that same time.

Also, were you previously using the old SmartLighting app? If so, those rules were migrated to the new architecture Smartlighting app. Check for that as well.

Thank you! I was able to delete the device using site. It took a while to locate where to find this but it worked. Been on smartthings for a long time and at this current home for about 8 years. Was able to delete and re-add a different device last month so unclear why this one would not delete from the app. It is the most current version of Smartthings app on a Samsung S22 plus (latest OS).

I was then able to add the device back in and appreciated that the app clearly showed in routines where the device has been removed and made it easy to add back into each one. Well done! Thanks again for your help. I have saved the URL for next time I need it.