Cannot Change Edge Driver to Aeon Labs/Aeotec

I have two Aeon Labs/Aeotec Smart Energy Switch G1s. They look like this. I use these for power monitoring for washer/dryer alerts (hence why I have two). During the past two weeks, they stopped working. Some searching showed me that this was due to the migration to Edge drivers. Sure enough, I logged in, and they were set to generic Z-Wave switches.

Since Aeotec publishes Edge drivers, I followed the instructions to add the proper driver, set it for the dryer, and it all worked fine again. However, when I tried to change the washer to the same driver, it gives me the following error:

Error changing device driver to “Aeotec Smart Switch Gen5”. Ensure that the driver you are trying to change to has a valid fingerprint match with this device.

Is this actually something I can fix? These two devices were purchased at the same time and do exactly the same function. If I can just get ST to change the driver, everything should work fine, but I’m stuck because it won’t let me change it because of a fingerprint mismatch or something. Is there anything I can do?

Check the Manufacturer code in the ST Advanced Web App or the community developed ST API Browser+ and post it here. If it’s all zeros, then the device is not paired with the hub properly and you will need to exclude it and re-pair to your hub. Be sure to add the device by scanning the QR code or by adding by brand. If you are prompted for the DSK, don’t skip adding it as that can cause pairing problems like the all zeros fingerprint.


Thanks. The device was showing all zeros. Deleted it and readded it, and it seems to work now. Thanks!