How do I Change to A Better Driver? (device stopped working after auto migration)

So i’m no developer, just a simple user. However about a week or so ago my Smartthings devices stopped working properly. My research over the last few days has led me to believe that I need to update to the proper "edge drivers’ for those devices. I’ve logged into what used to be called the IDE (which looks totally different now) and tried updated devices but each time I do I get errors.

For example, I have serveral Aeotec Smart Switch 6 installed that no longer seem to be working after the latest smartthings update… I noticed that a generic smartthings driver was being used so I found Aeotec driver “channel” which I enrolled in and downloaded the proper driver. However, each time I try and load it, I get the following error message: “Error changing device driver to “Aeotec Smart Switch 6”. Ensure that the driver you are trying to change to has a valid fingerprint match with this device.”

So I thought maybe I could do it through the mobile app instead, but alternative drivers don’t even show up in the mobile app.

Any help would be greatly appreciated as none of my window and door sensors work any longer which is extremely frustrating.

I apologize if this wasn’t the place to ask this question…

Any driver you want to use must already exist on your own hub.

If it is one of the stock drivers, then smartthings automatically put it on your hub during a hub firmware update.

If you want to use a custom driver, the author will give you a link to a webpage where you can “subscribe“ to their “channel“ and then select the specific driver that you want downloaded to your hub.

after that, when you open the details for the device in the smartthings app, as long as the fingerprint matches, the new driver will be available to select.

For more details, see the community FAQ:

FAQ: I have no idea what Edge is. Is that a new developer tool? (2022)

As far as valid fingerprint matches, check the fingerprint of the device. If it shows all zeros, it means that the device did not properly join to the network. If it’s a zwave device It’s also possible that it’s not joined at the right security level.

If the fingerprint and security level look good and the driver is showing as available on your hub, then I think I would get in touch with Aeotec-support and see what they say. Since it’s their edge Driver. :thinking:

Aeotec supplies Edge drivers for many of their devices including the Smart Switch 6. You can find information about their drivers and how to install them here.

The OP says they’ve already done that step, it’s just not matching with the device after download.

I should read more carefully when I’m multi-tasking :slight_smile:


Thanks for the quick response JD, appreciate it.

So I’m not exactly sure where “fingerprints” show up on the new IDE, but the device has a device ID populated. It also has a network ID, and presentation ID populated for it. Otherwise, manufacturer code and model are both NULL using the “stock” drivers. Are any of these things I listed the “fingerprint”?

The aeotec smart switch (link below) is a zwave certified switch so I would imagine the edge driver the manufacturer creates should be compatible with their devices. And i’m sure that i’m properly enrolled to their channel and have downloaded the proper driver. I just can’t seem to get the driver to load because of this “fingerprint” issue.

In fact, I can’t get any of the devices that aren’t currently working properly to update their drivers… every one of them gives me a similar fingerprint error message.

Also, for a little clarity, i’ve had my smartthings hub since 2018 (V2 hub). So although i’m not a developer, i’ve done my fair share of custom changes etc… but I can’t seem to get anything to work in this new IDE environment. And slowly but surely with the migration from device handlers to edge drivers a good portion of my hardware is now no longer working… Like my monoprice window&door sensors, or their dual relay controllers, etc…

Can you please elaborate on your statement above about “if it shows all zeros, it means that device did not join to the network”? Also I’m not familiar with devices joining at the right security level… i’m not sure i’ve ever seen that.

Please advise, and thanks for the help!

(Aeotec Smart Switch 6; Z-Wave Plus smart plug, 15A (ZW110) – ZWaveProducts)

In the new architecture parlance, Manufacturer Code is the “fingerprint”. If you have null values for your device, that is why the driver is not matching your device. You need to remove and reconnect your device so that the fingerprint is populated correctly. You can sometimes get null values if the device supports S2 security and you bypass setting it up (don’t pair with the QR code or skip inputting the DSK if prompted during other pairing methods).

In the old architecture, not being paired at the proper security level wasn’t as big an issue. The new architecture is more picky :slight_smile:

Also, because the fingerprints for your device were null, it’s likely the reason they stopped working because a generic “Thing” driver was installed.


The community FAQ explains about fingerprints and where to find them. Point 8.

FAQ: I have no idea what Edge is. Is that a new developer tool? (2022)

But, yes, it’s the manufacturer and model, and since those are null, there was a problem. @h0ckeysk8er has already given you the details on that.

Thanks for the info Bruce, that worked perfect! I deleted each device and re-added them back with great success. Only exception were some monorprice z-wave dual-channel relays that i’ve used for years. Got the hub to recognize them, and it adds them as a “multichannel switch” with two buttons, but doesn’t give me individual control of the internal relays. Seems both buttons control the same relay.

I know zooz makes the same dual-channel relays, but with these new restrictions, it won’t allow me to use their driver since the fingerprints don’t match.

Any idea how I can make those work? I’ve looked around and it doesn’t appear many people have used them.

Have you tried @Mariano_Colmenarejo 's “Z-wave switch and child Mc” driver? If gives you the option to create seperate child switches for each relay.

1 Like

Thank you very much Paul, that was it! Really appreciate all the help from everyone!