Cannot add my Ecobee to SmartThings (Invalid_Token error)

Hi guys, First time here.
I just bought and setup SmartThings Hub V3 and paired a bunch of devices through the house. I also purchased the New Ecobee SmartThermostat with Voice control. However, when I try to pair it to the hub, I cannot authenticate SmartThings with Ecobee because I can’t even get to the login prompt.
When I click on the page that says “Click here to enter Ecobee credentials” – I get the following page instead of a login page. Just a blank screen with the letters and numbers ending in “INVALID_TOKEN”

I posted some questions on the SmartThings FB group and still not help and I made a call this morning to customer support and they had trouble figuring out short of asking me to reboot my Ecobee and update my phones iOS which I have, and still didn’t change anything.

Has anyone encountered this and know a way around it? It HAS to be a SmartThings issue because the Ecobee itself functions fine and I had no problem authenticating with other devices including Hubitat, Alexa etc to access full functionality.

Same issue here, checked from different devices as well as Classis and new app, definitely seems like Smartthings issue, the Oauth link or Api for Ecobee may have updated or changed and Smartthings has not updated this or fixed it. Getting through to their support isn’t easy especially getting the right person to help fix the issue or understand whats going on.

1 Like

There is a FREE 3rd party app you can try…

Yup, know of it, but with Smartthings and Ecobee stating both are supposed to work with each other natively one would expect the integrations to work without issues. Anyways thanks for mentioning the App, but hopefully ST Support fixes the issue soon.

The most comprehensive ecobee integration is My ecobee device for SmartThings.

I’ve just tested it w/o issues and there are many more features than the ST stock one…

You can even get some comfort & energy savings tips using the Home IQ stats and the indoor/outdoor conditions at your home.

No other ecobee implementation is as resilient and exposes as many features & capabilities.

On top of it, you can enable targeted heating/cooling at your home using my zoning smartapps based on the concepts of rooms/zones/schedules.

The OP is asking for help with the stock SmartThings Ecobee support, so I’m not quite sure why someone would suggest a paid alternative as the solution.

@Rasi and @alik, your best bet is to notify both and VIA EMAIL, as your ticket can more easily be escalated/redirected to the appropriate support teams at both companies.


@storageanarchy thanks, have already done so, but Smartthings support is rather slow, last time I had them resolve an issue via email took them 2 month to respond back. Hopefully as you suggested emailing both ST and Ecobee might have them escalate the issue and resolve faster.


1 Like

Thanks. While I respect the efforts of the poster, I do want to stick to the stock app for now. After all, the whole reason I got ecobee is for its cross platform compatibility so it irks me that it isn’t working with ST. I did already setup a ticket with ST and Ecobee but it didn’t take very long for ecobee to figure out the issue wasn’t on their end. Let’s hope and wait and see. I hope Samsung resolves this issue soon.

1 Like

In my eperience, OAuth errors are usually transient - I suggest you retry every few hours or so to see if things have gotten cleared up. You might try using the SmartThings CLassic app on your mobile instead of the new one (or vice-versa) - the implementations might be a bit different for each…

@storageanarchy, neither Classic nor the new app works, nor does it matter which platform you try from.

Finally got an update from SmartThings Support. They are aware of the issue and have had numerous other mention the problem. Their developer teams are working on having this fixed asap, however do not have an ETA on when this would be, as they are not sure what the issue is.

Lets hope its fixed soon though.

1 Like

Thanks for the update. My ST tech was far less
Helpful and made me run around in circles. Glad if this gets resolved quickly. I will keep trying periodically but so far no dice with either the ST Classic or ST connect app

I was having the exact same problem over the past few days and I tried it again this morning and it worked! Hopefully you all have the same success.
Happy Holidays!