Cannot access devices when disconnected from wifi


I have been running my Lightwave RF switches via SmartThings for a few months now, and I have never been able to control things via the SmartThings app when disconnected from the wifi.

I assumed this was just because I didn’t have the SmartThings Hub or something along those lines.

Yesterday i setup a SmartThings Hub (it was needed for my z-wave doorlock), and I noticed i still cannot access from outside of the wifi network.

To test things, i installed SmartThings Classic (i have never used this before), and that is able to control everything when disconnected from wifi.

The current SmartThings App just shows “Checking status…” for all devices.

Does anyone have any suggestions?

Login to the GroovyIDE with your Samsung Id and password.
Click “My Locations” and click on your location, then click "“My Hubs” and select the hub (if more than one)
and finally click “My Devices”.

Check "Execution Location column to see which devices can execute local (i.e. without WiFi)

Just worked this out. My Android phone was using DNS. I switched over to Google DNS, and now it’s all perfect.

you may want to remove that link and use instead

users are going to see that link, bookmark it, forget the other instructions and get totally confused.

Wanted to confirm I was having the same issue and scottymeuk’s solution worked for me as well.

When connected to wifi on my android 10 phone, app worked fine. As soon as I disconnected and tried to connect / control devices over the cell network, the app just spun forever, said things were offline / disconnected etc.

Turns out a few months back I had setup “private dns” through cloudflare. Switching this off, back to default settings caused everything to start working again.