Can’t download addons, I can’t access any device settings

Hey everyone!
I’ve just tried to set up a new washing machine and it paired and registered absolutely fine.
However when it tried to download the add-on to control it, it got stuck on 0%.

So me being stupid, I uninstalled the ST app, the reinstalled it. Except now I need plugins for everything and it’s not working!!

It’s very possible it could be my internet connection but it’s happened across devices and over mobile data.

Has anyone experienced this before, or know how to fix it>

TIA :smiley:

1 Like

iOS by chance? There are two recent posts (oops 3 users now) with similar reported issue. Your best option may be to contact ST support.

It’s on my Galaxy A71, Pixel 6 and iPad Air 3rd gen. So likely a server-side issue or my WiFi connection.

Yup, happening to me too. Any time I try to access a device it spins the wheel for about a minute, then comes up with a message that I need to download a controller. When I hit OK, the wheel starts spinning again for another minute or so then get a message " cannot load controller at this time, try again later" Seems to be happening to all devices, although I haven’t checked all 76 of them Everything seems to be working correctly though. Did all the regular stuff, reboot iPhone, reboot hub, delete and reinstall app.

I’m having the same issue on my Galaxy s22 Ultra not able to download addons for my Washing Machine & Dryer, It’s been like this since the app was updated last month.

Must be down, just got the jetbot ai vacuum and can’t download the add on. Been trying for hours and based on this it’s on the server side so will try again tomorrow.

Glad it’s not just me, controls for my Samsung TVs were hectic last few days, so I decided to try everything to make them work again. Last solution was to uninstall Smarthings and reinstall. When adding TVs again, add-ons won’t install for either of them. All I’m getting is connection problem, regardless of what connection I use and it certainly isn’t a connection problem on my end.

P.S. Found a fix on reddit: using a VPN let’s you download the add-ons without any issues.

i also have this error with my soundbar 950a

@Sp1tfire Wich VPN and wich location did you use to make it work?

Known issue on 5 May 2022, should be fixed on 6 May 2022, so try again. If you still have the issue, report it to support.

Device controller issue 5 May 2022 [RESOLVED]

I used an app from Play Store that was setting VPN automatically, so don’t really know what location I used, but seems the problem is fixed now as I could download add-ons on my wife’s phone with my regular connection.

1 Like