Can SmartThings Button integrate with TuyaSmart Wifi sockets

Does anyone have a suggestion or know a way to setup SmartThings Button to control TuyaSmart compatible Wifi sockets? Can I control and access the SmartThings Hub from the TuyaSmart app?
Or myabe will the SmartThings Buttons integrate with the Tuya powered OWSOO Zigbee, Smart Home Bridge?

Yes, I tried connecting the TuyaSmart account in the the SmartThings app on a mobile phone, but only the automation programs are visible(cannot create or edit, only view them), SmartThings will not interact with the devices directly. To my understanding that’s the intended behavior is in the United States, whereas the integration seems to work just fine in other regions.

What my problem is I live in rather old house that has no ceiling lights, so there are no light switches to swap out. All the lighting is floor or table lamps. This 120+ years old house was built before electrical service was available and adding ceiling lights to the first floor rooms is not possible. So I have a plethora of TuyaSmart compatible wifi sockets all over the house controlling lighting and other devices.

I want to setup Smart Buttons of some kind to operate the lighting for people, specifically my 82 year old mother, that do not know where to find, then move various pieces of furniture, TVs, or the piano in order to press the manual button on the device. Voice activation? “I ain’t talking to a damn little box to run the lights. Why can’t I just turn the switch?”

I have already tried FLIC 2 buttons which do not integrate directly with Tuya compatible devices; however, you can create a jerry-rigged integration via the excessively slow IFTTT PRO service. The response time using IFTT is horrible it will take anywhere from 90sec to 4+ hours to respond. Nothing like having devices and lamps flashing on & off multiple times in the middle the night because IFTTT finally got around to processing the switch events from hours earlier. The FLIC 2 kit certainly was a waste of $219.

Any ideas??

I can’t even get my automations to show up.