Be aware of zwave replace


(Bobby) #1

I have been using zwave replace for months for my failed devices. It has been working great. But today, I tried to use it on a motion sensor that was used in Smart Lighting instances as well as CoRE. As soon as I clicked replace, it removed the device from my system completely. Don’t know if it was just an accident, but just wanted to make folks aware.


(Convinced ST will never be unbroken…) #2

LOL… just wait and see what their migration tool will do to your setup.


#4

Tagging @slagle


(Ben W) #5

Isn’t zwave replace a remove old and add new as same name as old function?

Were you able to add the device back in manually?


#6

It’s supposed to work a little differently than that.

With Z wave, the controller (in this case a SmartThings hub) assigns the network ID to a device.

With a replace utility, The hub is supposed to pair to the new device and give it the same network ID as the one you are replacing.

The idea of this is that it should not affect any of your other SmartApps or routines in any way because you never do a remove on the original device. The new device is supposed to just slip into the place of the old device using the old device’s network ID.

If instead, the network ID is being force removed from the system, you would then have to fix all of the smart apps and routines that referred to it.

So there is quite a big difference.


(Ben W) #7

Still the “old” device is removed in order to make room for the new device to take its place. You can’t have 2 devices with the same networkid.

I could see if the device was not responding/out of range it could get removed and failed to be re-added.


(Bobby) #8

Sure, but I also needed to add it manually in each app. This was an error that I didn’t see before. The beauty of the replace is that you don’t need to update manually each app that uses the device. The replacement is done behind the scenes. It’s a very nice feature that has saved me a lot of time in the past.


#9

Technically the old device is not removed. That’s just not how it’s done. Or at least not how it’s supposed to be done.

Remember that zwave is pretty simple. Individual devices don’t have a permanent ID. At the time of pairing, the controller (in this case the SmartThings hub) tells the device “I’m going to call you Charlie” (well, OK, number 38 or whatever). The device says, “OK, my name is Charlie” and stores that information along with The controller’s ID.

When there’s a replace, The human is supposed to have physically unplugged The device to be replaced, or it was broken in the first place.

So when you do a replace, the hub first sends out a message, “Charlie, are you there?” When it gets no response, it then tries to add a new device, and when the new device responds, it says “I’m going to call you Charlie.”

There’s no removal step. And no exclude is done on the original device. That’s because the design assumption is that the old device went bad. So as long as it doesn’t respond, the controller thinks it’s gone forever.

If the human then plugs the second device back in and there was nothing wrong with it, you do have a problem. Because now there are two devices name Charlie. Things will not go well. But there isn’t anything in the replace process to prevent that human error from happening.


(Bobby) #10

And now you made me think, without a proper exclusion my ‘Charlie’ is most likely a ghost now. And the new ‘Charlie’ which is 1C (old Charlie was 63) confuses the system even more, because the humanly name is the same as ghost Charlie. That may explain why even I readded the sensor, most apps are not listed as using the sensor. What a mess.

On a slightly different topic, I never understood why devices with ‘removed’ status are still present in the list of devices:

this is the ‘removed’ sensor - note the apps that were using it

and this is the newly included sensor - note in use apps. I manually added the sensor to all other apps but they don’t show


#11

Last time I ran into one of these, there was a platform bug where once you had added a device to the IFTTT manager, it stayed added no matter what. You had to get support’s help to remove it. I don’t know if that’s still true.

@slagle might know.


(Tim Slagle) #12

Reaching out to support is the best bet here. They can get this looked at for you.


(Jason "The Enabler" as deemed so by @Smart) #13

Soaking of ghost devices, I was in the IDE earlier and I had a couple of devices that show a status of removed… Hmmmmmm? ? They show up under hubs/devices