Bad switches possible? ( two switches constantly go "unavailable")

leviton

#1

I have had a Vera system with 1 Yale door lock, and a Honeywell thermostat for 4-6 years. Recently (over the past month or so) I replaced it with Smartthings and added 2 Schlage locks, 8 Leviton switches, 1 Leviton dimmer, 2 arrival sensors, 2 motion sensor, 2 Aeon Multi senors, 1 Zigbee plug (to help the arrival sensor pick up in the garage), and an Iris garage door opener.

Everything was working well for the first couple of weeks and now I have two switches that constantly go “unavailable”. I can turn them on via the app (when “unavailable”), but they do not report back as on, so I cannot turn them off. If I go into the IDE and change the device handler (from say Z-wave switch generic to just Z-wave switch) it will work for a couple hours or so and then go unavailable. One of these switches is in the garage so distance COULD be an issue, but the Iris G-door opener works flawlessly in the same area (does Iris g-door opener extend Z-wave? if so distance should not be an issue). The second offender is in the main room with the 7 other switches 10-15 feet way, which all work great. I have also tried removing them from the network and then adding them back in. It worked OK last night, and this morning they are back offline.

In closing do you guys think I got a couple bad switches or is there another issue? I dontt have any z-wave software that will show the network, and from what I have read that is a lot more work than returning a switch.

Thanks for any input.


#2

This is an ongoing issue with the SmartThings platform and rarely has anything to do with the individual device. :disappointed_relieved: You can search the forum and you will find many discussions about unavailable devices Of all brands and models. Sometimes it’s a range issue, and of course it’s always possible it is an individual bad device, but more commonly it’s just a sort of ghost effect of the platform.


#3

BTW, it might be a good idea to contact support and just see if they can see anything from their side. :sunglasses:


#4

That sounds like unreliability :cry:

I found an odd “fix”, but it may be short lived. If I tell Alexa to turn the offending light on, she reports back that it is not working (check power supply or some foolishness), however the device turns on and immediately shows up in the ST apps.

Before doing this I had removed the switch from my network again I lost about 6 devices is ST app. I told Alexa to turn them on/lock them one by one. She said the same thing as above, but they all came back. It has been about on hour, so fingers crossed.


(Jimmy) #5

Any errors when performing a z-wave repair?


#6

I did get an error in my first repair with a multi sensor. I plugged and re-plugged it and reran. Repairs now complete successfully.

Update - Alexa fix does not really work (figured it wouldn’t last). However Alexa can still turn it off and on, but I cannot see the updated status via the app and it does not control them (not “unavailable” just not clickable).

On the phone with ST support :thinking:


#7

It is unreliability, but it is at the platform level rather than the device level. It has to do with the cloud monitoring of “device health” which appears to misrepresent the actual state of the network fairly often. Anything you can do to get the cloud status updated will usually resolve the issue for an individual device for a while, but then either that device or another one may be marked off-line again in the cloud, even though it is still fully responsive to the hub.

Just search the forums for either “unreliability” or “device offline” and you will find many discussions.


#8

@JDRoberts - thanks for the explanation, makes sense; still stinks. Tier 1 support was pretty useless and Tier 2 won’t call back until Tuesday or Wednesday, nice.

I found something that may or maynot help. both my bad switches are missing everything in “Data” and missing the “switch:off” under current state.

All my working switch do and look like this.

I have tried removing the switches and adding them back in. When I do they show up as “Z-wave Relays” not switches, unless I edit the device type in the IDE.


#9

Sounds like they may have a different firmware level or something else which is causing them not to be recognized with the correct model. Did you try changing the DTH individually in the IDE from the one that doesn’t work to the one that does?


#10

If by DTH you mean device type handler listed as “Type” (sorry still a newb), yes I changed it to the same as the other switches but the “switch:on”/“switch:off” does not show up.

I am almost certain this is my issue. When I turn the garage lights on they report as Device/switch/off .

Doing the same test with the bad switch does not report Device/switch/off

The commands are sent and the devices responds (it does turn off and on), but the status is never updated so the ST app it not usable.


#11

http://thingsthataresmart.wiki/index.php?title=Acronyms


#12

Sorry, I use voice reader software and can’t read your code includes. Hopefully some other people will come by who will be able to help, but it does sound like there may be a firmware difference.


#13

Teir 2 support must have done something. My hub was just rebooted, (I noticed when my arrival sensors “arrived” without moving) and all of a sudden everything is working great. Current States now has “switch:on/off” status and the app is working. Thanks @JDRoberts for the tip to contact Samsung support. I didn’t like the response they gave me, but they got it fixed pretty quickly.


#14

I was able to resolve the Leviton switch being added as a Z-wave Relay by removing the switch, factory resetting the switch, and re-adding it. The following process got it going again.

Remove the switch from the network (remove in app while you press up on the switch till LED goes amber, release and click up once)

Factory reset the switch (hold up on the switch for 30 seconds until it flashes red)

Add switch back to SMT (hold up till LED is amber push up once).

I know I found this somewhere, but wanted to documented it again for anyone else having the issue (or me next time it happens). Thanks.