Automations ignoring sunrise/sunset time shift after creation [Feb 2021]

I created a couple of automations using the sunrise and sunset time object and noticed that after I’ve created the automation, the time it triggers never actually updates inline with the real sunrise or sunset. It’s like it takes the values for that particular day and uses them forever. I know that my location is configured correctly, and that the ST hub knows what the sunrise/sunset values should be because I can see those updating in the IDE, but it’s clearly ignoring those for triggering automations. Is anyone else having this issue, or is there anyone from SmartThings who can take a look or offer some advice please?

To confirm the problem, I have set up a test automation which toggles a virtual switch on or off allowing me to keep a record of when it would trigger the event every day. See the screenshots for my automation, the history log from the switch that’s being triggered, and also the actual sunrise/sunset times from the IDE for the day.

I am having the exact same problem. Have smartlighting installed, have tried changing time zones etc. Have updated Weather Station. In IDE the sunset and sunrise times display properly and update daily. The automations just don’t trigger at those times, they trigger at the sunrise/sunset time of the automation on the day it was created and stay that way. It used to work, not sure when it stopped.


Exact same problem here too. I wonder if you found a solution?

I don’t know what the latest is on this, but ST are working on it. Don’t get distracted by the IDE and Weather Station, that is legacy stuff.

The Automations apparently never did change sunrise and sunset times every day, they were only updated once they’d drifted away from the correct times a bit. That correction hasn’t been happening.

The times will be updated whenever you save the Automations. I find a good way to do that quickly is to add a space on the end of the name. That allows the Automation to be saved but the trailing space doesn’t stick. Not a solution but if the time drifts too much for you to bear you can at least deal with it.

Nope, no solution yet and no reply from SmartThings to my support request. My workaround is to use webCoRE because that appears to adjust its sunset/sunrise times properly.

Just an update for anyone who may stumble across this post - I’ve had a reply from SmartThings support today:

After taking another look into this and getting some more eyes on this for you, I can see that our team are aware of this issue and are currently working on it.

Please don’t worry, we are aware that there are multiple users having the same trouble with their sunrise/sunset automations so this is being investigated. Please keep an eye out for pending updates which we hope will fix this.

In the meantime, if you have any further concerns, give us a shout.

In regards to the sunrise/sunset automations. . . I have pulled my hair out overt his and the ability to trigger regular Automations with Sunrise/Sunset is definitely broken. By regular I mean the automations in main SmartThings menu. It does not matter whether your IDE shows the right times, whether your geolocation is updated, whether you have installed the Smartweather Tile, or whether you update weather station or Smartlighting in the IDE. Nothing changed the fact for me that sunrise/sunset were frozen in time as of the time I created or updated the automation.

However the sunset and sunrise triggers DO work if you set them up as SmartLighting Automations under the Smartlighting SmartApp (as opposed to regular automations defined above. Go into SmartApps, make sure SmartLighting is installed, and then go into SmartLighting to create an automation). SmartLighting Automations must have their very own logic. The only downside to setting up the automation here is that the capabilities are a little limited - for instance you can’t do multi-trigger automations, and there may be some devices you cannot control. You may need to set up some virtual switches to accomplish something complex. But it works. Now if only they didn’t create two places to see my automations. . .

Also, I recently got the message - “We’re having trouble connecting. Check your network connection and try again”. I got this message after android updated on my phone. Couldn’t figure out what was going on and I consistently got the message. Didn’t immediately make the connection, then I realized android added Smartthings shortcuts in the Android Settings bar. Being a little suspicious of what that was doing, I disabled it, and lo and behold I no longer got the error message when trying to access Smart Lighting.