Automations Based on SmartThings Home Monitor Not Working

Automations in the NEW SmartThings app (not CLASSIC) that use SmartThings Home Monitor security modes as a trigger are not working.

For example: IF SmartThings Home Monitor == “Disarmed” THEN Send text message.

In this example, the text message is not sending when I change the security mode from Armed to Disarmed. This seems like a bug?

1 Like

I created a test automation using that condition and action - it worked for me.

I suspect it’s an issue with the migration from Classic to the new app, which I did last month. I rebuilt all these automations from scratch but something else must be wrong. I really miss the Classic app…

Text messaging works for me too.

However, I recall that in the STHM when I was setting up Set Response and selected ‘Send Text Message’, that SmartThings offered to authorize text messaging support in SmartThings. I’m can’t remember if it ever offered to authorize text messaging from anywhere else in the app.

It doesn’t matter what actions I put under “THEN”. None of them fire. This automation does not run when I arm and then disarm the security.

Can you post a screenshot? Blackout any sensitive data

I just edited my previous reply with a screenshot.

Looks fine. So why can I get it to work and you can’t - that is the interesting question.

So, if you change the state to armed (stay or away) on the STHM card in the dashboard, wait 5 seconds and change it back to disarmed… nothing happens?

That is correct, yes. SHM is not triggering any automations it seems.

My first tHought is to uninstall/reinstall STHM and see if that resolves the issue. But, that means you would need to recreate any and all automations that were tied to it and also do the settings in STHM again. That will be a pain and I am not certain it will resolve the issue - it might.

Have you contacted ST support?

I have reached out to ST support and I’ll wait to see what they say before uninstalling and re-installing again, especially since I already had to go through that when I migrated from the Classic app.

Try deleting this automation and recreating it from scratch. That seems to sometimes work.

I recall that their used to be some language setting bug that could cause STHM issues too.

BTW, I new I had to authorize SMS somehow. SmartThings sent me a text message that I had to respond ‘YES’ to in order to activate SmartThings SMS.

Take a look at this thread about SMS support in SmartThings.

Deleting the automation and recreating it again did not resolve the issue.

I believe STHM is active because we have alerts set up with the Noonlight service and I can confirm that triggering the security sets off the alarm and notifies Noonlight. It just seems like automations don’t work…

1 Like

Having a similar issue - no automation to change STHM or based on STHM actually works. I can get notifications, etc. validating that my automation runs, but for instance it never actually disarms or arms STHM.

Did you ever make any progress on this?

check out this thread…


Son of a biscuit, literally just tried my automations that sync STHM to other things and now it works. Hallelujah! Now to get rid of some infinite loops I apparently created in the automations… ha!

I am syncing a Nexx Alarm device which acts as a keypad to my security system w/STHM arm stay/away/disarm.

I want to sync alarm status --> SHTM and SHTM --> Alarm, so I had to create automations both directions. I’m afraid in some cases this could cause some infinite loops and already saw some weird behavior. Any ideas how to keep it from going “oh alarm armed, better arm STHM! oh SHTM armed, better arm alarm!” over and over?