Arlo Pro Not Recording

I have a custom smart home monitor set up so that whenever there is motion detected on the Arlo Camera on my porch, I’ll get a text message from SmartThings telling me so and the camera will record for 30 seconds. I can then review the video recordings in the Arlo app. This setup has worked perfectly fine for the last 1.5 years I’ve had the camera. However, I noticed the last two days that when I get a text message saying there’s motion on the camera, there is no corresponding recording. Nothing has changed in my SmartThings ecosystem to trigger this, it just suddenly started doing this two days ago. Anyone have any ideas?


I can’t find the message now, but ST sent out an email advising of Arlo integration problems either yesterday or the day before. They’re aware and working on it.

1 Like

Found it.

Oh great, that’s helpful, thanks. Wonder why I didn’t get that email.

@iketricktor- I’m re-reading your initial post… would you mind sharing how you’re accomplishing (or how you WERE :slight_smile: )?

1 Like

Here you go! And then I set up a separate mode called “Camera Off” to turn this configuration off while I’m working on stuff on the porch, as you can see it’s not including in the list of modes where this configuration is active.

My six Arlo Pro 2 cameras record when they detect motion individually but do not record with other rules I have set up with door contacts and other motion sensors. The history says the rule is activated and they record but they do not. I think it is because they are set up to record when motion is detected like that in the Arlo App. I cannot turn them off or on in the ST’s App’s anymore either. I know if I call the support line they will tell me to uninstall and reinstall my App’s and when that doesn’t work they will tell me to uninstall and reinstall my cameras and all the automations I have set up with them. Same solution for all problems.

has there been any solution to this? I am still having the same issue with my Arlo cameras recording. thank you.

I haven’t had it resolved yet, but I did get an email from Smartthings support after I opened a ticket with them that it’s a known issue and is getting worked on.

I was able to resolve this issue. I realized that the “smartthings” mode in the Arlo App, for some reason deleted the cameras used for recording. I re-added the cameras that need to record in the Arlo “smartthings” mode and voila! everything is back to normal and all my cameras are recording via smartthings!

so, here are the steps:

  1. Go to Arlo App
  2. Edit “smarthings” profile using the pencil icon
  3. under Rules -> "If motion on "–> hit pencil icon next to it --> choose “Detects motion”, --> below in the “Then do the following:”, “Add your missing camera <>”—> choose “Record video”–> hit pencil icon to set length of record
  4. SAVE

That should do it

I hope this help the community!


Thanks for the info but this didn’t fix the Arlo recording problem using the SmartThings motion or contact sensors as a trigger in the Smart Home Monitor. Many users are complaining about this in the Arlo Community Forum under the Partner Integration section. This problem appeared after the Arlo firmware update in late August.

@Cybersurfer this does not work for me. Since I have had my cameras and smartthings I have always had the mode as “disarmed” in Arlo app and it has always worked fine.