Arlo Pro 2. Can’t Add Camera?

Hey Guys,

I had 3 Arlo Pro 2 Cameras working Perfect with ST! A few months ago things started to go haywire with the Cameras and ST. I removed the Cameras from ST.

I tried to add them back and just couldn’t do it. I forgot about it till today and decided to remove all the Cameras from Arlo and I also unlinked them Arlo from ST.

I added the Cameras all back to Arlo, disarmed them and then went to ST Device Add. I clicked Arlo, gave ST the credentials for Arlo and it said it was added successfully. But I still don’t see any camera, don’t ever see any cameras to choose to add, nothing! I tried this multiple times deleting everything even the apps.

Is it just no longer possible to add the Arlo Cameras or is there a way to do this that I’m missing? I can’t believe the instructions are not listed how to do this? The instructions I’ve used don’t work.

Thank you very much for any help you can give.

just checking… in the ST app, you went to menu > settings > linked services and removed the Arlo integration?

Yes I did. Thank you!

Are the cameras suppose to show up in this page because they don’t? I click on Arlo at the top and then it takes me to the next screen where it asks me what room I want.

Have you checked the Groovy IDE website to see if any placeholders for the Arlo cameras are still listed as devices after you deleted them from the app? If so, delete then there too.

No DaWeav I have not and will try and figure that out now. Thanks for the reply, just seeing it now. For some reason not getting emails about replies.

Just checked and it says that I don’t have any hubs, devices, or place holders?

Is this the problem?

are you logging in at https://account.smartthings.com

Thank you JKP, no I wasn’t logging in on that page. All my devices are now showing along with one hub. No cameras are showing. No Handlers. The only thing I see out of place is there are two entries for my iPhone in Devices.

if one is showing as offline, you can probably go ahead and delete it

They are both saying on line.

Is this Camera thing common? My cameras were working perfect with SmartThings. Now nothing.

i don’t know the answer for that. hopefully someone with arlo cams will step in and offer assistance.

1 Like

That’s good that it didn’t leave any ghost device residue.

Another trick would be to power cycle the Arlo Base Station then once it’s back online in the Arlo app, go to the SmartThings app linked service for Arlo to see if that does anything.

Also, here is a massive thread that somewhere in it might lead you to a resolution. This thread is about when they changed the old ‘Arlo Connect’ linked service to the new ‘Arlo’ linked service.

1 Like

Thank you very much DaWeav, I will give it a try and read that thread.

Will post if I get it going!

Still can’t get an answer! Trying to figure out how to clear the Cache.

You stated go into the ARLO App and then find the linked ST App? I don’t see any ST App linked in the Arlo App.