Are there one or two types of Sonoff Basic?


(Saif Alharrasi) #1

Hi,

I got in gearbest TWO link of sonoff. I want to buy some sonoff to connect them with ST by IFTTT.
Because I failed to flashing 2 sonoff basic devices.

1-

2-

So, are there any different or they are same and all are support IFTTT??

Thanks


(Steve ) #2

No they’re the same one i believe people struggle flashing them if they’re newer so use NodeMcu instead to do the flash.


[RELEASE] Sonoff, Sonoff TH, S20, Dual, 4CH, POW, & Touch Device Handler & SmartApp ($5 & $10 Smart Switches)
(Saif Alharrasi) #3

thanks @Steveuk23

I asked because the box of them is different. one of them like this

other one like this

about flashing :: I used FTDI …


(Saif Alharrasi) #4

I bought this one https://gloimg.gbtcdn.com/gb/pdm-product-pic/Maiyang/2018/01/19/source-img/20180119153917_69252.jpg

And I’m worried that it does not work with IFTTT. Because I want connect it with Smartthings HUB :grin:


(Steve ) #5

Yeah they’ve re branded the boxes I did notice that but the device is the same.
If you leave it as it is without flashing it I don’t think it will work with ifttt but when it’s flashed it will as it’s through SmartThings then.


(Saif Alharrasi) #6

@Steveuk23
Now eWelink App is compatibility IFTTT

check this link at (7:56) :::

and itead site:
https://www.itead.cc/smart-home/sonoff-wifi-wireless-switch.html

about flishing I will try to buy nodemcu


(Steve ) #7

Ah right thats good about IFTTT.
No i meant NodeMcu flasher.
thats the software you use to flash the firmware onto the sonoff instead of the ESPeasy


(Saif Alharrasi) #8

Can I flash that previous sonoff devices again??


(Saif Alharrasi) #9

I tried it with previous Sonoff device but flashing not work by this flasher.


(Steve ) #10

Yeah you can flash them as many times as you want are you following the guide on the community and using the right firmware.
Have a look on there it has all the settings you need


(Saif Alharrasi) #11

good …

I follow the steps in readme file which that link you are send.(What is mean “GPIO0 MUST LOW.”)


if you have a guide file or video will be better.

I used the firmware which in this link:


(Steve ) #12

Try following this guide


(Saif Alharrasi) #13

I tried it and flashing completed but I cannot get the wifi of sonoff!!!


(Saif Alharrasi) #14

Hi @Steveuk23
I mean, I cannot detact sonof wifi


(Steve ) #15

Did you follow that guide ?
Did the flash go ok?
If so power on the Sonoff and then hold the button for 20 seconds then the LEDs should flash.
Turn the power off then back on again and the WiFi should show up then.


(Saif Alharrasi) #16

Yeah
I follow that guide and that flashing is complete success as shown.
Also I power on the sonoff and then I hold the button, but the LED not flashing. :sob:


(Steve ) #17

Do you have the wires going in the right way?
One side is input one side is output.
Also when looking for Wi-Fi search for only 2.4ghz not 5


(Saif Alharrasi) #18

@Steveuk23 The wires going right in input side
There is no any new wifi is shown


(Saif Alharrasi) #19

Thank you for your help @Steveuk23


(Steve ) #20

Not sure what else you can try if you say it flashed correctly and it’s wired correctly and you’ve tried resetting it.