Sonoff Basic config issues won't switch from ST but does on HTTP

(Dave Accendo) #1


I am new to smart things and have managed to integrate my Hive, Harmony , Hue and Lifx without issue but Sonoff i am struggling with.

I flashed my Sonoff basic with Tasmota & a Sonoff POW and added 2 handlers, Sonoff Connect & Sonoff Wifi switch, i can connect to the sonoff via http and switch it on and off without issue.

I added the new device via its ip in the smart things app marketplace, my problem is that it just does not want to talk to the the switch via smart things.

What i have noted is that in live logging when i use ST on/off it logs an entry for on & off, ST app shows the device as unavailable ?.

Any help would be greatly appreciated as i am getting no where fast :frowning:

Here are some of the live log files responses .

35868320-bc95-4563-be9a-bf4600170f21 12:39:29 PM: error Device type ‘Sonoff POW Wifi Switch’ in namespace ‘erocm123’ not found. @line 93 (manuallyAddConfirm)

35868320-bc95-4563-be9a-bf4600170f21 12:39:29 PM: debug Creating Sonoff Wifi Switch with dni: c0a802d8:0050

35868320-bc95-4563-be9a-bf4600170f21 12:38:55 PM: debug getChildDevices(false), children=0

f22817b0-5533-4c85-9d72-b608cb53198e 12:38:50 PM: debug getChildDevices(false), children=0

f22817b0-5533-4c85-9d72-b608cb53198e 12:38:50 PM: warn DEPRECATION: You no longer need to call ‘unsubscribe’ within the ‘uninstalled’ method.

f22817b0-5533-4c85-9d72-b608cb53198e 12:38:47 PM: debug getChildDevices(false), children=0

5eb574f6-b85d-4ecc-b4c9-8ab6897858f8 12:38:30 PM: debug off()

Not sure if this is helpfull :slight_smile:

(Maarten) #2

Problem here 2. Have 2 Tasmota’s on 5.1 and one on 6.1. And ST won’t find the switch, although the smarttings IDE website did find it.


When you say it won’t FIND them, what do you mean? You have to define the ip in the DTH.

(Dave Accendo) #4

Excellent , that’s what i was missing , the bin file i used did not have the option to enter an i.p address which i have now done and its working 100%.

Thank you so much :slight_smile: