Aqara switch WXKG03LM & WXKG02LM not working properly

I have 2 types of wireless switches that I intend to use to switch some lights on/off

I have added the device handler from bspranger “Xiaomi Aqara Wireless Switch” and published for me.
I then added in my switch(s) using the ID from the catchall. The switches appear but do not work.

In the mobile app i can see the switch but i cannot see its status change if i press the button physically.
It only seems to work if i press the screen button for mementary in the app. In the mobile app it does not even show the battery status correctly. I can only also see the device events for this switch if i press the screen button on the app and nothing if i use the physical switches.

Help. I’m lost.

Regards Adrian

Which version of the SmartThings mobile app are you using - The new Samsung SmartThings Connect app, or the SmartThings Classic app?

All of the custom Xiaomi / Aqara device drivers are not currently supported for use in the new app.

Hi Keith

Thanks. I actually managed to figure this out last evening too.
Its not obvious though.

Ive also got the 2 switches i have to work as a 2 way lighting system for my hallway (1 switch at each end of the hall)

Best Regards
Adrian

1 Like

@Adrian_Priestley What was the issue … bcos i’m having the same issue … my aqara switches work via the app but not physically … battery is good and activity light on the switch flashes twice after i press the button on the device?

Bump.

I’ve same issue, have a WXKG02LM that’s setup to run Webcore automation using the DTH from @bsrpanger.

Worked perfectly for well over a year but switch has stopped responding. I’ve deleted the swith from smartthings classic app, eventually re-added and waited for battery signal. Tested and all three button presses worked perfectly. Assuming I was back in track, I reinstalled in the hall but by this evening the switch was unresponsive. I’ve checked battery and unit for damage.

Anyone got ideas?