Xiaomi WXKG03LM — Help needed

I’ve just received a WXKG03LM in the post and I’ve successfully paired it with my v3 SmartHub using the customer device handler from bspranger. I also have a WXKG02LM which I’m not opening until I get the first switch to work.

In the classic SmartThings App it originally appeared as ‘Thing’ and I updated it to use the Xiaomi Wireless Switch handler (v0.92). In the classic app there is no button configuration for this device. This then presents in Homebridge as an unsupported device.

I’ve tried searching the forum and whilst I’ve found plenty of posts regarding bsprangers gihub and handlers, each thread jumps all over the place and often gets highjacked by someone asked about a completely different sensor.

I have seen this thread - Xiaomi Aqara wall switch (WXKG03LM) - but this was just regarding pairing. I have successfully paired a single button (it can be done) but now can’t use it.

Thanks in advance for any help given!

About an hour after this capture was taken, the device has update with the battery level. At the same time the Button configuration section has completely vanished

First off, for both the WXKG02LM / WXKG03LM Aqara Smart Switches, you need to use the correct custom device handler that I made, which is here.

Also, there are two revisions of the WXKG02LM / WXKG03LM smart switches, a 2016 revision which only supports single-press functionality, and a 2018 revision that supports single- and double-press, and hold.

See this post for more information:
(make sure to scroll down to the header " [RELEASE] Aqara Wireless Smart Light Switch DTH v0.9.2")

Also, see this post with information on how to identify the revision of your WXKG02LM / WXKG03LM smart switches:

Let me know if you have any other questions after you’ve got the correct device handler installed.

1 Like

Great job! I have my WXKG03LM running now. Thank you!

Hey - I wanted to express my thanks for this post, and that of the ST community working on Xiaomi Aqara integration. I’ve just had success with using your device handler to link a WXKG03LM (single button switch) directly to my v2 ST hub… I didn’t realise i had the 2018 version until i found the double click functionality working. I’m definitely going to buy more of these.

I’ve now got it setup as a secret kill switch for the TV power socket to avoid my kids from overdosing on TV during their Covid confinement! A big thanks from all family :slight_smile: