App for SmartThings Outlet - Pulsed Output Response?


(Ray Krasko) #1

The normal response of pressing the SmartThing Outlet Icon, on the SmartThings mobile phone interface, is touch = on or touch = off.

Is there an app that creates a 2 sec on followed by off response (pulsed on response) to a touch of the icon?

Thanks,
Ray


#2

You could do this quite easily using webcore.


#3

Here is a piston for you to do just that.
If you instal webcore you can just import this piston using the import code in it and select your outlet.

Job done :+1:t3:


(Ray Krasko) #4

Thank you for the quick and helpful response. It is exactly what I needed.

I created a WebCoRE account. I have tried to register the e9ohw code, however, the page only accepts the first 4 characters.

I’m just learning the SmartThings/WebCoRE environment so I ask for you patience. The WebCoRE IDE seems like it will be a very powerful development environment.

Thanks again for your help.

Be well

Thanks,
Ray


#5

Here is the instructions for installing webcore.
The import code is for importing the piston I made for you.
It sounds like you are trying to use it to register a browser.

Please check the installation instructions.

Good luck.


(Ray Krasko) #6

I tried that path and got to the 3rd step where it say to click in Setting but I don’t see a Settings tab. Do I need to Enable GitHub Integration first in order to get the Setting Tab?


#7

It is far easier if you do enable github. Saves a lot of hastle.

But if you would rather not then here is a link to setting it up manually without github.


(Ray Krasko) #8

Enabled the GritHub and have the 4 code blocks loaded (WebCoRE, Dashboard, Piston, Storage), however, I must have missed clicking the Publish checkbox before clicking Execute Update. Now I have all four blocks installed but the installation is not complete.

Is there a workaround/correction I can make?

Sorry for my miss-step


(Robin) #9

You can open each code block in turn and click the publish>for me option at the top of each one.


#10

Like he said. :stuck_out_tongue_closed_eyes: Sorry. Couldn’t reply sooner. Was driving!


(Ray Krasko) #11

All four reflect Published so that’s done, however, it did not trigger an Install of the Dashboard as the YouTube video suggests.

Can you please advise (whilst not driving)

Thanks


#12

Have you followed the instructions to enable OAuth for the app. And then followed the rest of the instructions below it to install the smart app and authorise all your devices you wish to use with webcore?

Follow. 4.3 then 4.4 then 4.5 and 4.6 of the wiki

Click this link below to get to the rest of the installation instructions.


(Ray Krasko) #13

Thanks to your help I have the WebCoRE Dashboard up. Tomorrow I will try to import your code and then add to it from there. I am looking forward to using the development environment.


(Ray Krasko) #14

I am trying to register my browser so I can access the WebCoRE Dashboard on my PC.

I got the 3 minute duration code from my iPad, entered it, along with my webcore login information. Then a screen comes up asking to authenticate using Home/webcore password. I reentered the webcore password, which I know to be correct but it is not accepted?

Circling ever closer :slight_smile:

Thanks for your assistance.


(Robin) #15

You only need the register a browser code for the first page, password for the second page.


#16

Excellent. You’re almost there. Just to confirm, on your iPad if you go to the smartthings app.
Once loaded. Click on the middle icon at the bottom “Automation” then the rightmost tab “smartapp” then select “webcore” then register a browser.


This will give you your browser registration code.
Then navigate to the address shown. Once there you will input the code you have just been given.
Next is the password screen. This is the password you set up in the settings of webcore. If it’s not working for you and you are sure it is correct. Just try changing it in the settings.


#17

Try just using the register browser code. Don’t put any webcore login details in on this page.

I don’t think I’ve ever put any webcore login details in ever?
:thinking:


(Robin) #18

The login details section isn’t active yet… so above guidance from @Baz2473 is all you should need.

Just to check, did you enable oAuth in the ST web IDE?


(Ray Krasko) #19

That worked.

Thanks.


(Ray Krasko) #20

Even when the options menu is selected it doesn’t show the WAIT construct as a possible selection. I looked in the wiki and it was show as crossed of the to-do list and you used it.

Sorry to be so needy