SmartThings Community

Anyway to remove power consumption from GE zigbee light switch history


(Louis Dupont) #1

From time to time the Smart Lighting based automation appears to fail to turn off a GE zigbee light switch at a specific time. I can’t catch any of these events. I’d like to see from the log whether it really failed to turn off the light or if something else made it turned it on in the meantime. Problem is the Recently tab if flooded with the power consumption history. Anyway to filter out or disable this? Thanks


(Mike) #2

No
Twenty characters


(Scott G) #3

You can disable it with custom code in the device handler. If this device is running locally on your v2 hub with Smart Lighting then using custom code will move it to the cloud. You may see new latency.


(Louis Dupont) #4

[quote=“Sticks18, post:3, topic:36957”]custom code in the device handler[/quote] Thanks. Just to make sure I understand. We’re talking about re-implementing the device handler altogether? Am I right to assume that I’m getting myself into a lot a work?


(Scott G) #5

Not really. A little copy/paste and editing. If you haven’t implemented any custom code before, then there’s a small learning curve, but you can check out the FAQ on custom code below.

Basically you’ll create your own version of the GE zigbee switch devicetype by copying the code available on ST’s github or using the From Template option in the IDE (developer area of ST, not intimidating though). Once you do that, you just need to edit the line:

sendEvent(name: “power”, value: powerValue)

and make it say:

sendEvent(name: “power”, value: powerValue, displayed: false)

Then apply that new devicetype to your device.


(Kevin Tierney) #6

Myabe try changing the switch to a generic “Zigbee Dimmer” instead of the GE specific one. From loooking at github, it looks like the generic one does not include power consumption. If it’ll work with your switch, it’ll still work with offline smart lighting rules and won’t require custom code