Android App Update Version 1.7.41-25 (Dec 21, 2019)

Anyone else notice the UI responding much faster (after the lengthy first time startup). It seems snappier overall and even noticed that devices display much quicker within rooms.

I’m still seeing huge gaps within history though. I have an entry at 9:20am and then the next is 10:30 pm. Kind of makes history rather useless.

I’ll tell you after I get it. I’m still on 1.7.40-21. I sure hope so…

I was actually just going to post something about this (performance) because last night at dinner my family had an “intervention” discussion with me about SmartThings. My wife is insistent on me putting Classic back on her phone because the new app is significantly slower than Classic on her older phone (and she absolutely hates the new UI), but I’ve also noticed how slow the new app is compared to Classic on all my Android devices.

That’s when my daughters chimed in and ganged up on me with my wife. I got an earful about how slow the new app is, the unreliability with phone presence, but mostly about how the new UI just plain “sucks”, like as in slow to update, finding and getting to devices and Rooms, settings don’t stick, and tons of scrolling around in the new app (we have a lot of devices, so that’s kind of expected).

We literally had Classic side by side with the new app on similar phones, and when you do that comparison I can see their perspective on why they feel that way. To be honest, me too. I ended up re-configuring a few of our Minimotes to control the devices they really wanted, as well as working through helping them do more with voice control with Alexa to help them out a little more.

To add insult to injury, when we called my dad to wish him a happy birthday, he gave me an earful too! My parents are a few hours away, and I have them on ST with a few devices so we can help keep an eye on things. They’re still on Classic, but I have shown them the new app on my phone. In their own Greek language kind of way, they told me no way on earth do they like the new app.

Boy do I have a change challenge ahead of me. I just really hope that the new app keeps getting better, faster, and easier to use…

EDIT: Something is up, but not sure what. I still haven’t got the update, but my phone’s app keeps doing odd things that it never did before. If I stay on the Dashboard for any length of time, the app closes. If I stay on a device’s page for any length of time, the app goes back to where I was previously - either the Room or Dashboard. If i stay in a Room, the app goes back to the Dashboard, and then closes. This just started happening today that I’ve noticed. Perhaps something changed on the back end of ST to address changes being released in a newer release? I have no idea, but something aint right this morning…


Over the last week my bride was in Michigan visiting family so I decided it would be a good time to “clean up” things. I have been adding and changing over the years and couldn’t remember how or where things were being done in my Automation rules. They were scattered between routines, scenes, smart lighting, automation creator and webCore. Some actions had rules in all of them. A nightmare to make changes to or troubleshoot. I tried using the new app while rewriting things and it just plain sucked. It’s just really, really, really buggy. Did I mention that it’s full of bugs. I saw everything your family was complaining about. Crashes, slow device updates, no device updates, etc. I ended up using classic most of the time. Not because I couldn’t navigate the new UI, because V3 is just plain unstable.

Before my bride left I set up the new app on her phone but told her not to use it yet. I’m going to keep it that way for now. She can use classic but get the notifications from V3 until I see the stability of V3 get drastically better.

1 Like

It’s still taking forever for STHM to initially come “on line” and show the sensors connected but the app no longer force closes when you try and look at the sensors before the show online. That’s a plus.

@johnconstantelo this goes to show women are invariably always right, listen to your wife!


Here is something new:

It looks like these “quick controls” show up after you make changes to the quick controls on a device page. They appear at the bottom of automations. I’m not sure of the purpose or usefulness? I must be missing something. :thinking:

1 Like

Read the announcement, it is mentioned there.

It feels a bit faster, but it shows still network errors for things. And takes time to update device tiles.

A few days ago a new user reported that the temperature histogram is broken. It is indeed with the new version too.

Hi - We have found the history unreliable with large gaps too. This is also on the latest update. I agree makes it almost useless now. As an example we had numerous entries up to 2pm yesterday then nothing until today. I can’t say it’s any faster and on 2 Samsung S9 phones we still have to close it and reopen it the first time as the scenes do not work. This was before and after the latest update.

1 Like

That just showed up last night! :smiley:. I really dislike when software is released without release notes. Though it’s like opening a Christmas gift. What did I get this time.

The histogram on my Honeywell thermostat and weather tile are working ok. Hour and day are completely populated. Minute is not always but that could be due to frequency of updates. I think minute is new or I just never noticed it before. I don’t look at histogram very often. I have found that histograms in custom DTH do not always work. The histogram in my keypad has never worked but, ST doesn’t even support keypads so the DTH is definitely a hack. With proper documentation, I’m sure it could be made to work though.

I think they did make some changes to the way DTH are being processed. Previously, the DTH for my UEI keyboard had some weird tiles, but opened and the settings could be edited. Now it says “checking status” on the main tile and editing it generates a network error. But the changes made while editing or to settings do “stick” so it’s basically a cosmetic issue. So far, this is the only device I’m getting a network error on. My Hampton bay fan controller doesn’t throw errors but doesn’t update correctly (it never has in the new app). This is again another custom DTH.

There is a bug in the iOS app where you can’t remove the quick control in Automations once it is created. Even if you turn off the setting in the device, that quick control remains in the Automation list. Are you experiencing this in the Android app?

Stupid question @jkp, but where is the “turn off” setting for this? I would really like to delete most of these that automatically populated.

If you open the device, there is the block where you can enable/disable the timer, power on and power off. But in the iOS app, disabling those will not remove the quick control. And there is no way to remove the quick controls from the Automation section either. So currently, it appears you can’t remove any of the quick controls that I can find.

It looks like they are there forever in Android too.

I would like to be able to just “swipe” them away. Or better yet, put on option on the device tile for the user to decide if it should be a quick control. Sometimes I’ll do a timer, or power off as a one time thing (usually for testing). I don’t need a quick control.

Actually, if the device tile is in the dashboard, it’s just as fast to open the tile from there as it is to go to Automations. Automations just seems like a weird place for this. Maybe it’s own “room” like scenes would be better?

Though not as bad as the previous version, I have encountered the UI failing to update devices, the app just hanging when trying to change the name of a device, and just plain fail to load a page. During one of the renames I even had to force stop and clear cache to get the app to come back. Still plenty of bugs that need to be squashed. It’s better than the last version though so it’s a step in the right direction. :slightly_smiling_face:

1 Like

Setting up my new Galaxy Tab A 10.1 and my living room ceiling fan is showing offline. It works though. Not a big deal. I look at the same fan in my Galaxy S7 phone and the fan is online. WTH?

Found something else different between the Tab A and the GS7. The GS7 has gaps in the history. The Tab A doesn’t. History appears to be complete in the newly setup tablet. I’m wondering if it would be worthwhile to delete the new app on the GS7 and reinstall it fresh? I hate to lose all of my settings but if I duplicate them in the tablet, it will be easier to just duplicate them back in the GS7. Anyone see these kind of differences between two devices?

The tablet is now missing history too. This bug really needs to be addressed if you even want to casually use the new app for ANY TROUBLESHOOTING at all. I know I can use the IDE but I ought to be able to look in the app to see when a switch turned on and off.

Screenshots from V3 app vs. Classic from today:

1 Like

Yup, I can confirm this bug and it sucks that something like this made it through any QA process. It’s not working for any device, and History (via the hamburger menu) has also stopped showing history from all devices. I still see history for automations that execute.

Still no icons in classic!


I was moving a newly created virtual switch into the living room when the app force closed and restarted. Ok, it happens a lot but I’m getting used to it. When the app came up all of my room customizations are all gone.

I am taking back my thoughts about the app being 90% ready. It’s not. There are WAY TOO MANY UI bugs for this app to be a daily driver.

If your still using the classic app. Stay there until they fix the UI in this app. It’s like they have no one testing before they release this crap!

What I’m finding is that anytime I edit two devices consecutively, the app gets confused and crashes. I really can’t believe that made it through testing.